2.4L Camshaft Position Sensor Revised? - Pontiac Solstice Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 07-10-2019, 10:31 AM Thread Starter
Member
 
chickenwire's Avatar
 
Join Date: Mar 2012
Location: Michigan
Posts: 4,840
2.4L Camshaft Position Sensor Revised?

Getting a P0010 code, read the background, looks like a no-brainer and simple fix. BUT...

My sensors have the connectors coming straight off the top (first pic.) Everything I see available shows the connectors making a 90 degree turn directly away from the mount hole (second pic.)

This would place the connectors turned toward each other and in direct conflict with the head, wouldn't it?
Attached Thumbnails
Click image for larger version

Name:	cs9.jpg
Views:	12
Size:	156.3 KB
ID:	98121   Click image for larger version

Name:	index.jpg
Views:	11
Size:	4.0 KB
ID:	98123  

2007 2.4L N/A. Stock + some pretty crap.
chickenwire is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 07-10-2019, 11:58 AM
Member
 
Join Date: Aug 2018
Posts: 16
Those are not the right ones then. I got mine off Amazon.
Genuine GM 12655420 Camshaft Position Actuator Solenoid Valve https://www.amazon.com/dp/B00F675VI8..._lCIjDb41SB91J

Genuine GM 12655421 Camshaft Position Actuator Solenoid Valve https://www.amazon.com/dp/B00F675WNW..._6CIjDbJX1ZCCQ

Sent from my Pixel 2 using Tapatalk
bouttreefitty is offline  
post #3 of 9 (permalink) Old 07-10-2019, 12:46 PM Thread Starter
Member
 
chickenwire's Avatar
 
Join Date: Mar 2012
Location: Michigan
Posts: 4,840
Thanks bout. That's what I thought but every "parts store" I went to and searched by year, make, etc. let me to the one I pictured above.

2007 2.4L N/A. Stock + some pretty crap.
chickenwire is offline  
post #4 of 9 (permalink) Old 07-10-2019, 12:51 PM
Member
 
Join Date: Sep 2006
Location: Lexington, KY
Posts: 5,386
Quote:
Originally Posted by bouttreefitty View Post
Those are not the right ones then. I got mine off Amazon.
Genuine GM 12655420 Camshaft Position Actuator Solenoid Valve https://www.amazon.com/dp/B00F675VI8..._lCIjDb41SB91J

Genuine GM 12655421 Camshaft Position Actuator Solenoid Valve https://www.amazon.com/dp/B00F675WNW..._6CIjDbJX1ZCCQ

Sent from my Pixel 2 using Tapatalk
Quote:
Originally Posted by chickenwire View Post
Thanks bout. That's what I thought but every "parts store" I went to and searched by year, make, etc. let me to the one I pictured above.
Those links are to the solenoid valves, but your post is asking about the sensors.

John
Lexington, KY
Sky NA 2007 Midnight Blue
Sky RL 2008 Carbon Flash - Naked
JohnWR is offline  
post #5 of 9 (permalink) Old 07-10-2019, 01:26 PM
Member
 
Join Date: Aug 2018
Posts: 16
John is right, you were asking for a cam position sensor, but put up a picture of the actuator. since you said something about the p0010 I knew that's what you were looking for

Sent from my Pixel 2 using Tapatalk
bouttreefitty is offline  
post #6 of 9 (permalink) Old 07-10-2019, 02:06 PM Thread Starter
Member
 
chickenwire's Avatar
 
Join Date: Mar 2012
Location: Michigan
Posts: 4,840
Yeah, but a search on "camshaft position sensor" kept bringing up the actuators!

Thanks again, and as always, for the help and clarification.

2007 2.4L N/A. Stock + some pretty crap.
chickenwire is offline  
post #7 of 9 (permalink) Old 07-10-2019, 03:12 PM
Member
 
Join Date: Aug 2018
Posts: 16
No problem, glad to help

Sent from my Pixel 2 using Tapatalk
bouttreefitty is offline  
post #8 of 9 (permalink) Old 07-10-2019, 07:01 PM
Member
 
Join Date: Mar 2019
Location: at the snow white beaches of north west florida...or in the shop, but never on the couch. possibly playing pool.or eating
Posts: 247
your issue is more than likely the accuators, thats what the cam shaft position sensor is telling you....not that the sessor is bad but that it is sensing the cam isant addvancing/retarding as it is told to do. witch is the accuators job to do. the accuators are about $22 on flebay. the sensors are about $18 for the gm unit, on sensors I will do the gm stuff, for the accuators....I doubt it matters.I got the $22 ones off flebay with the life time warranty, and I got a china sensor thatw asent working right,,,,I get a gm sensor for about $16, but the oe one is doing fine. with the codes sometimes you have to think ahead or backwards of what it is trying to tell you. ....it's telloing your sensor...well the sensor is reading right but the reading is rong....so not the sensor, but rather what should be making the sensor read right...the accuator. as it is what gets the signal; from the computer to addvance/retard the cam.and the sensor tells the computer what it has done...if it has done nothing....you get the sensor code. kinda like a woman...hard to figure out sometimes...ok Im rong , it's all the time.
marksbug is offline  
post #9 of 9 (permalink) Old 07-10-2019, 07:05 PM
Member
 
Join Date: Mar 2019
Location: at the snow white beaches of north west florida...or in the shop, but never on the couch. possibly playing pool.or eating
Posts: 247
the sensors are at the rear side of the heads.about a inch below the valve cover on the right and left side of the head,10 mm bolt and they slide out.then disconnect the wire when you get the sensor to where you can do it.... but I would change the accuators first, since they do have a habbet of going south when your headed north..it added possiably 20 hp or more to my car.witch i was happy to see since it was a slug of a turn when I bought it..witch i just thought was GM.
marksbug is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac Solstice Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome