Pontiac Solstice Forum

Pontiac Solstice Forum (https://www.solsticeforum.com/forum/)
-   General Tech, Platform Common Issues & Solutions (https://www.solsticeforum.com/forum/f12/)
-   -   2007 Solstice GXP (https://www.solsticeforum.com/forum/f12/2007-solstice-gxp-158149/)

Vasquezz1228 04-09-2019 09:56 PM

2007 Solstice GXP
 
I have owned the car since January and the first problem I ran into was the fuel pump sending unit. Ended up changing out the pump to be safe. The car is stock with the exception of an airbox mod I did and a gutted cat. Car was tuned by me using HPTuners and has been since before I bought the car. Yesterday I got the cel on and I had a code for "bank 1 too lean at idle" and "catalyst efficiency below threshold". when I hooked my laptop on the fuel trims were off by 0.3 which imho is pretty good(I love how I can get the lnf fuel trims that close). So I erased the codes and went on with my day. I disabled the cat code on the tune. Worked fine last night and today until I turn on the car around noon and get the "eng pwr reduced" message and right away I thought oh no I'm in limp mode. But the car runs fine, drives fine, holds 22 psi at wot and there are no CELs. Car drives like normal but the message comes on now Everytime I start the car. Has anyone e experienced this before?? Any ideas what's going on? I usually associate that message as a problem with the throttle body. But the car runs fine and does not have a rough idle or anything.

ChopTop 04-10-2019 05:36 AM

How old is the battery?

Vasquezz1228 04-10-2019 12:29 PM

The battery is about 1 year old, you think it might be going bad?

LatinVenom 04-10-2019 02:07 PM

You mentioned gutting the cat, so is possible your sensors are either not working or look at the settings with your HP tuner.
Just a thought. Also check the grounds but if it is starting fine then those should be fine.

JohnWR 04-10-2019 02:28 PM

What is your airbox mod? You could have done something to confuse the MAF, although that should give you a CEL.
"Engine Power Reduced" without a CEL has a history of being caused by throttle problems: actuator, position sensor, and/or throttle pedal position sensor.

Vasquezz1228 04-11-2019 02:33 AM

Logged it today and the car is running fine, o2 sensors are working properly. I did have the "too lean at idle" code again and once I deleted it the "eng pwr reduced" message when away. I guess instead of the triggering a cell it triggered EPR instead. That makes sense as there were no throttle issues when in the supposed limp mode. Car ran like it always does just had the message on the DIC.

After some research I have been pointed to look towards a purge valve in the fuel tank. Apparently that causes lean at idle and when filling up the tank the fuel comes back up the filler neck. I'm thinking that might be my issue.

Vasquezz1228 04-11-2019 02:36 AM

Also an airbox mod is when you remove the resonator for the air box. Makes more noise and more power. Apparently that is the belief. It is tuned and the MAF was adjusted as well so there are not any problems there. Had had the mod and tune for more than a year already and this issue just started 2 days ago


All times are GMT -6. The time now is 01:16 PM.

Powered by vBulletin®. Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome