Passing inspection - Pontiac Solstice Forum
 3Likes
  • 1 Post By joybill44
  • 1 Post By Rick Bennett
  • 1 Post By firsttimeowner
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 03-28-2019, 04:16 PM Thread Starter
Member
 
firsttimeowner's Avatar
 
Join Date: Jul 2012
Posts: 50
Garage
Passing inspection

So had problem with my red top battery this winter, got it replaced for free so thatís fine now!
But I took it in for inspection and I had cat not ready and evap also
So how long to you need to drive for those codes to disappear. Should disconnect battery for ten minutes ?
How about it gurus ???
firsttimeowner is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 03-28-2019, 05:33 PM
Member
 
joybill44's Avatar
 
Join Date: Feb 2014
Posts: 248
Had the same problem a couple of years ago. Replaced the battery and took the car in for inspection the next day. Took it to three different inspection stations and it wouldn't pass any of them. Called my local GMC dealer, explained the situation to them and they told me to drive the car for a couple of days (about fifty miles) and try again. Im not a computer guy but the dealer told me that a dead battery causes the computer to lose some information that is necessary for inspections and that driving for a while replaces that lost info. It worked!
Sting Ya likes this.
joybill44 is offline  
post #3 of 8 (permalink) Old 03-28-2019, 05:37 PM
Member
 
Sting Ya's Avatar
 
Join Date: Nov 2010
Posts: 3,486
The car goes through a relearn process whenever the battery is disconnected what I did per my local GM service advisor was start the car let it get up to operating temperature drive it a couple of miles shut it off and repeat 10 times just to be sure either method will work .
Sting Ya is offline  
post #4 of 8 (permalink) Old 03-28-2019, 06:19 PM
Member
 
Rick Bennett's Avatar
 
Join Date: Oct 2018
Posts: 54
Garage
the car has to go thru a 'drive cycle' to pass all the monitors, do not unhook the battery that will just reset all the monitors and you will have to keep driving it
stevebot39 likes this.
Rick Bennett is offline  
post #5 of 8 (permalink) Old 03-28-2019, 08:43 PM
Member
 
Join Date: Jan 2019
Location: LaSalle, Ontario, Canada
Posts: 26
Just went through this with my Torrent, did some work to remove CEL,(replaced EGR valve and gas cap) Evap codes-drove it to garage which was 20 kilometres away, and it failed due to not enough history, drove another 40kilometres, brought it back and it passed.
Zinger is offline  
post #6 of 8 (permalink) Old 04-05-2019, 07:37 PM Thread Starter
Member
 
firsttimeowner's Avatar
 
Join Date: Jul 2012
Posts: 50
Garage
Well I passed
Had to drive mine more then 100 miles
Still had the evap canister not ready but it was working according to the reading is on the tester ?
Wo ho
But today we had Snain hoping for warmer weather.
sirwm likes this.
firsttimeowner is offline  
post #7 of 8 (permalink) Old 04-06-2019, 11:58 AM
Member
 
Join Date: Mar 2019
Posts: 22
Oklahomans fixed the problem by voting out inspection loving politicians. That was in 2001 and the world did not end.
okiebill is offline  
post #8 of 8 (permalink) Old 04-06-2019, 12:34 PM
Member
 
stevebot39's Avatar
 
Join Date: Dec 2016
Location: OH, AZ
Posts: 311
Garage
Same here. Car stored with a tender but 10 year old OEM battery finally failed. New battery, then inspection the next day. Not Ready. EPA gave a recommended "cycle" to drive, but I just drove normally and came back the next day and passed. It just takes time for all the sensors to register, which includes enough driving to warm the cat converter.

SteveBot39
Winter Solstice, Tucson AZ - '09 NA Automatic Cool Silver Coupe; DDM Supercharger, MagnaFlow cat and exhaust, ESTuned; GXP sway bars, DDM chassis kit; Stoptech brakes; Michelin PSS tires; Pioneer radio w/ NAV and b/u camera. Plate SOL N AZ

Summer Solstice, South Euclid OH - '09 NA Auto Mysterious Black Coupe; DDM Supercharger, MagnaFlow, DDM chassis kit, Hawk brake pads, Conti EC Sport tires on Black ASA wheels, Advent radio w/ NAV and b/u camera. Plate SOL 4 OH
stevebot39 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac Solstice Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Passing Inspection! MF656174 General Solstice Discussion 0 01-30-2011 02:50 AM
Other cars revving engine when passing. SolsticeVA General Solstice Discussion 25 08-29-2007 10:24 PM
Why Do Drivers Hog The Left/Fast/Passing Lane??? (is This You?) Solstice62 Other Car Discussion 64 08-08-2006 06:11 PM
Passing Gear? pogo765 General Tech, Platform Common Issues & Solutions 2 05-31-2006 04:58 AM
Passing, for now... bbradshaw Getting Your Solstice 11 01-20-2006 01:05 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome