2007 GXP OBD codes after upgrade - Pontiac Solstice Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-04-2018, 12:48 PM Thread Starter
Member
 
Join Date: Mar 2018
Posts: 1
2007 GXP OBD codes after upgrade

Hello guys, Im new here and looking for some help. About me, this is my first entry into small displacement turbo cars. My vehicles prior to this have all been pre 80s camaros, firebirds, and then of course new duramax pickups. I purchased an 07 GXP with 90k on it cash for 6k in pretty good shape, always liked the looks of these cars. I ordered from DDMworks the power pack, which included CAI, charge tubes, and trifecta tune, and ordered SOLO performance exhaust. Prior to install I flagged code P0101, and noticed my turbo would typically peak at 14, however periodically wouldnt excede 2 psi. I replaced the MAF, and installed the charge tubes, CAI, and have yet to install exhaust. After those were installed I took it for a short drive and gassed it up. This morning I started it to a very rough idle and it died twice, then idled ok for a few minutes then got rough again. I shut down the vehicle, and read the codes. <p2178, p0101, p050A. any advice┐

ps: I{m on my friends laptop and it{s a spanish keyboard so.... yeah, sorry for bad spelling and punctuation, everything I type is flagged for typos lol
Jeremy Weingart is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-16-2019, 04:41 PM
Member
 
johnwickman's Avatar
 
Join Date: Apr 2019
Location: St Johns Florida
Posts: 17
I have the same codes and symptoms. How much boost should I be seeing? I am seeing sometimes up to 15 or 16 psi but under light acceleration I am seeing none. I hope it is not a cracked IC as I can't afford a new one right now. Can they be fixed with something like JB Weld?
johnwickman is offline  
post #3 of 4 (permalink) Old 07-16-2019, 04:58 PM
Member
 
Join Date: Sep 2006
Location: Lexington, KY
Posts: 5,565
How stock is your car? P0101 is a MAF sensor signal problem and can be caused by a dirty MAF sensor. Oiled air filters can cause that.
I can't find the other two in the service manual.

Under light acceleration you may not see any boost, and in first (and maybe second) gear you are only going to see 10 psig maximum.
Full boost will happen in fourth gear and wide open throttle.

John
Lexington, KY
Sky NA 2007 Midnight Blue
Sky RL 2008 Carbon Flash - Naked
JohnWR is offline  
post #4 of 4 (permalink) Old 07-16-2019, 07:12 PM
Member
 
johnwickman's Avatar
 
Join Date: Apr 2019
Location: St Johns Florida
Posts: 17
Quote:
Originally Posted by JohnWR View Post
How stock is your car? P0101 is a MAF sensor signal problem and can be caused by a dirty MAF sensor. Oiled air filters can cause that.
I can't find the other two in the service manual.

Under light acceleration you may not see any boost, and in first (and maybe second) gear you are only going to see 10 psig maximum.
Full boost will happen in fourth gear and wide open throttle.
Thanks, the car is bone stock. 95K on it. I just replaced the MAF, wonder if I got a bad one. The codes cleared up for about a week after I replaced it. I did change the spark plugs today. They were not fouled but the gap was pretty high, .050 to .055 on the gauge.

Last edited by johnwickman; 07-16-2019 at 07:15 PM.
johnwickman is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac Solstice Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome