Radio/CD display not working - Pontiac Solstice Forum
 2Likes
  • 2 Post By 1955c1d6
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 09-11-2019, 10:46 PM Thread Starter
Member
 
1955c1d6's Avatar
 
Join Date: Sep 2017
Posts: 13
Radio/CD display not working

Our 2008 GXP stock radio/CD display decided to not light up when the CD or radio is turned on. The radio functions but you get no readout as to station or CD info. Wondering if anyone has experienced this problem and what might be a potential fix. We have a 2008 GXP w/16,000 miles.We have had all the recalls done.
Attached Thumbnails
Click image for larger version

Name:	IMG_1055.jpg
Views:	11
Size:	364.9 KB
ID:	99295  
Attached Images
 

Last edited by 1955c1d6; 09-11-2019 at 10:48 PM. Reason: can't get the attachment correct
1955c1d6 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 09-12-2019, 04:33 AM
Member
 
Join Date: Sep 2006
Location: Lexington, KY
Posts: 5,669
Is the DIC (Driver Information Center) display visible?

To get your picture to display correctly try saving it as a different name, then attaching it. It sounds crazy but usually works.

John
Lexington, KY
Sky NA 2007 Midnight Blue
Sky RL 2008 Carbon Flash - Naked
JohnWR is online now  
post #3 of 8 (permalink) Old 09-12-2019, 05:54 AM
Member
 
TomatoSoup's Avatar
 
Join Date: Aug 2009
Location: Gaithersburg, MD
Posts: 6,650
^ What John said... check the dimmer control first.

If not that, try a BFH... err ... sorry ... try tapping on the front center of the radio in case the front panel connectors have become dirty

Owner of "Campbelle", a Brazen 2008 GXP ... with mods piling up...
TomatoSoup is offline  
post #4 of 8 (permalink) Old 09-13-2019, 10:58 AM Thread Starter
Member
 
1955c1d6's Avatar
 
Join Date: Sep 2017
Posts: 13
John, yes the displays on the consol behind the steering wheel are working. The only thing that is not working is when you turn the radio/cd on there are no lights showing on the radio screen. Strange but same thing happened on my 2007 F150. We never had it checked out to find out why. I wonder if it is just the led components of the time burning out?
1955c1d6 is offline  
post #5 of 8 (permalink) Old 09-13-2019, 11:00 AM Thread Starter
Member
 
1955c1d6's Avatar
 
Join Date: Sep 2017
Posts: 13
Tomato, tried tapping and the dimmer switch but radio lights are still not functioning. Dare I take it to the dealer?
1955c1d6 is offline  
post #6 of 8 (permalink) Old 09-13-2019, 01:30 PM
Member
 
TomatoSoup's Avatar
 
Join Date: Aug 2009
Location: Gaithersburg, MD
Posts: 6,650
Quote:
Originally Posted by 1955c1d6 View Post
The only thing that is not working is when you turn the radio/cd on there are no lights showing on the radio screen.
Just to be clear, the button backlights are not working, but the radio display *is* working? Or neither display nor backlights are working?

In either case it's unlikely that ALL the LEDs failed at once. I suspect that it's the faceplate that has failed. Good news (if you are up to the DIY) you can pretty much buy any radio that has the same display and swap out the faceplate circuit board (there's just clips and a couple of screws holding it all together).

If I were you, before I did anything else, I'd just open up the dash, take out the radio, take off the faceplate and put it back on and try it again -- just to clean the connector.

See also: https://www.solsticeforum.com/forum/...b-radio-62652/

Owner of "Campbelle", a Brazen 2008 GXP ... with mods piling up...
TomatoSoup is offline  
post #7 of 8 (permalink) Old 09-14-2019, 08:39 AM Thread Starter
Member
 
1955c1d6's Avatar
 
Join Date: Sep 2017
Posts: 13
That worked! (that or the threat of taking her to the dealer.) All is good. Apparently just making contact. I guess I will have to use the car more.....
TomatoSoup and CycleCat like this.
1955c1d6 is offline  
post #8 of 8 (permalink) Old 09-14-2019, 05:15 PM
Member
 
chickenwire's Avatar
 
Join Date: Mar 2012
Location: Michigan
Posts: 4,902
Quote:
Originally Posted by 1955c1d6 View Post
That worked! (that or the threat of taking her to the dealer.) All is good. Apparently just making contact. I guess I will have to use the car more.....
To follow up, if you use the "aux" jack - don't leave the cable plugged into it - it will oxidize and the contact gets wonky - similar to what you just experienced with the face plate.

2007 2.4L N/A. Stock + some pretty crap.
chickenwire is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac Solstice Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome