Starting issue - help? - Page 4 - Pontiac Solstice Forum
 5Likes
Reply
 
LinkBack Thread Tools Display Modes
post #46 of 59 (permalink) Old 07-04-2019, 04:42 PM Thread Starter
Member
 
Northern Sol's Avatar
 
Join Date: Jul 2008
Location: Windsor, ON
Posts: 2,986
Quote:
Originally Posted by chickenwire View Post
Glad you found the solution. For $200.00 I'd come up to the great white north and change it out for you! lol
Hey, I’m in Windsor so not far. Come on over. I might even be south of you. (Lol)

Mods: too many to list!

2007 GXP manual. Bought new Sept 2007
The Mean Machine
2009 GXP Coupe Auto # 526. Bought May 2016 - 1800 miles
The Ace of Spades
Northern Sol is offline  
Sponsored Links
Advertisement
 
post #47 of 59 (permalink) Old 07-04-2019, 05:14 PM
Member
 
Join Date: Sep 2006
Location: Lexington, KY
Posts: 5,523
Quote:
Originally Posted by chickenwire View Post
John - is it a "proximity" sensor? Honestly I understand the function of the "switch" but didn't know if it was a physical "switch" or a sensor.
It sends a 0-5V signal to the BCM, but I do not know if it is solid state or some sort of variable resistor. The manual doesn't say what it is, only what it does.

John
Lexington, KY
Sky NA 2007 Midnight Blue
Sky RL 2008 Carbon Flash - Naked
JohnWR is offline  
post #48 of 59 (permalink) Old 07-04-2019, 06:30 PM
Member
 
Join Date: Aug 2006
Posts: 16
I had the same problem...push started...took it to my mechanic...replaced battery...everything is good now.
Larrygun is offline  
post #49 of 59 (permalink) Old 07-05-2019, 06:57 AM
Member
 
TomatoSoup's Avatar
 
Join Date: Aug 2009
Location: Gaithersburg, MD
Posts: 6,602
Quote:
Originally Posted by JohnWR View Post
It sends a 0-5V signal to the BCM, but I do not know if it is solid state or some sort of variable resistor. The manual doesn't say what it is, only what it does.
Are you sure it's an analog level device? Both of my schematics (2006 NA & 2008 GXP) show it as a simple switch.

Also, but slightly unrelated, a google search seems to indicate it is a commonly used device - so common that AutoZone (etc) carries them: https://www.autozone.com/electrical-...ntiac/solstice. And see description from O'Reilly's: https://www.oreillyauto.com/detail/b...solstice?pos=2

Owner of "Campbelle", a Brazen 2008 GXP ... with mods piling up...

Last edited by TomatoSoup; 07-05-2019 at 07:00 AM.
TomatoSoup is offline  
post #50 of 59 (permalink) Old 07-05-2019, 07:36 AM
Member
 
Join Date: Sep 2006
Location: Lexington, KY
Posts: 5,523
Quote:
Originally Posted by TomatoSoup View Post
Are you sure it's an analog level device? Both of my schematics (2006 NA & 2008 GXP) show it as a simple switch. .........
I was, but now you are making me question myself. You can be sure that I will check tonight.

John
Lexington, KY
Sky NA 2007 Midnight Blue
Sky RL 2008 Carbon Flash - Naked
JohnWR is offline  
post #51 of 59 (permalink) Old 07-05-2019, 08:09 AM
Member
 
chickenwire's Avatar
 
Join Date: Mar 2012
Location: Michigan
Posts: 4,868
Quote:
Originally Posted by TomatoSoup View Post
Are you sure it's an analog level device? Both of my schematics (2006 NA & 2008 GXP) show it as a simple switch.

Also, but slightly unrelated, a google search seems to indicate it is a commonly used device - so common that AutoZone (etc) carries them: https://www.autozone.com/electrical-...ntiac/solstice. And see description from O'Reilly's: https://www.oreillyauto.com/detail/b...solstice?pos=2
I wouldn't be surprised if it was a common switch, especially if it's only $12.00. (You can bet your a$$ if it were Solstice specific it would be a helluva lot more expensive!)

2007 2.4L N/A. Stock + some pretty crap.
chickenwire is offline  
post #52 of 59 (permalink) Old 07-05-2019, 03:25 PM
Member
 
Join Date: Sep 2006
Location: Lexington, KY
Posts: 5,523
Quote:
Originally Posted by TomatoSoup View Post
Are you sure it's an analog level device? Both of my schematics (2006 NA & 2008 GXP) show it as a simple switch......
Well, I have now either learned to not assume that anything was kept consistent from year-to-year, or to not trust my service manuals. Or both.
I will definitely be checking the year more thoroughly in the future.

My 2006 Solstice and 2007 Sky Service Manuals both identify the clutch pedal position devices as simple switches.
My 2008 M-Car Service Manual identifies it a an analog sensor. Either my manual or yours is incorrect, but I have not yet looked to see what I actually have.
Attached Thumbnails
Click image for larger version

Name:	08-09-034 2.0 Sensors.jpg
Views:	3
Size:	938.4 KB
ID:	98005   Click image for larger version

Name:	08-09-342 2.4 sensors.jpg
Views:	3
Size:	939.9 KB
ID:	98007   Click image for larger version

Name:	08-17-366 CPP Relearn.jpg
Views:	3
Size:	1,021.8 KB
ID:	98009   Click image for larger version

Name:	08-17-367 CPP Relearn.jpg
Views:	3
Size:	954.0 KB
ID:	98011  

John
Lexington, KY
Sky NA 2007 Midnight Blue
Sky RL 2008 Carbon Flash - Naked
JohnWR is offline  
post #53 of 59 (permalink) Old 07-05-2019, 05:47 PM
Member
 
numbbers's Avatar
 
Join Date: Feb 2006
Location: Sun City, AZ
Posts: 914
Weak Battery

Quote:
Originally Posted by sirwm View Post
I'd say 'yes'.

not all batteries are created equal.

some have lasted 12 years, others 12 weeks.


But double checking the battery connections as suggested above is a good idea too
Down here in the desert, my batteries last 3 years max. I have tried optimas but they do not last any longer. Now I just buy the cheapest battery I can find.
TomatoSoup likes this.

Thanks, Dave Russell

Mallett #33
VIN #1G2MB35B27Y106697
Platinum Pearl over Deep
Ebony Leather

Custom Arelli
numbbers is offline  
post #54 of 59 (permalink) Old 07-31-2019, 09:54 PM
Member
 
Join Date: Jul 2019
Posts: 1
Hi all. New to the forum partly because I'm at wits end. 2008 GXP that won't always start. As others have noted, dash lights and radio come on then I turn the ignition and nothing. I've had it towed 4 times because of this. Mechanic diagnosed as clutch ignition switch? He has replaced twice but it still is happening. He showed me that I can turn ignition and jump on clutch a few times until it cranks. That saved me a tow bill tonight but this is really frustrating. Thoughts?
Radiodude1! is offline  
post #55 of 59 (permalink) Old 08-01-2019, 06:44 AM Thread Starter
Member
 
Northern Sol's Avatar
 
Join Date: Jul 2008
Location: Windsor, ON
Posts: 2,986
Went to dealership yesterday and the wrong part came in. Will go back in two weeks when new part arrives. I am not freaking out as she is not acting up as much. As per advice from dealership I make sure I depress clutch hard and all the way down. She then, 95% of the time starts up right away. Will update once part arrives.

Mods: too many to list!

2007 GXP manual. Bought new Sept 2007
The Mean Machine
2009 GXP Coupe Auto # 526. Bought May 2016 - 1800 miles
The Ace of Spades
Northern Sol is offline  
post #56 of 59 (permalink) Old 08-01-2019, 09:27 AM
Member
 
Join Date: Sep 2006
Location: Lexington, KY
Posts: 5,523
Quote:
Originally Posted by Radiodude1! View Post
Hi all. New to the forum partly because I'm at wits end. 2008 GXP that won't always start. As others have noted, dash lights and radio come on then I turn the ignition and nothing. I've had it towed 4 times because of this. Mechanic diagnosed as clutch ignition switch? He has replaced twice but it still is happening. He showed me that I can turn ignition and jump on clutch a few times until it cranks. That saved me a tow bill tonight but this is really frustrating. Thoughts?
If the radio turns off while you are holding the key in the start position, the ignition switch is working.

Pumping the clutch pedal suggests the the (switch or sensor) on the pedal is not working, and may need to be (adjusted or calibrated). It may also be loose, so you could contort yourself under the steering wheel to check it.
Quote:
Originally Posted by Northern Sol View Post
Went to dealership yesterday and the wrong part came in. Will go back in two weeks when new part arrives. I am not freaking out as she is not acting up as much. As per advice from dealership I make sure I depress clutch hard and all the way down. She then, 95% of the time starts up right away. Will update once part arrives.
Do you know what they ordered, or what it should have been? As I read the manuals, the '07 is supposed to be a switch, but the '08 is analog. TS had some different information, so I am really curious about what you actually have.

John
Lexington, KY
Sky NA 2007 Midnight Blue
Sky RL 2008 Carbon Flash - Naked
JohnWR is offline  
post #57 of 59 (permalink) Old 08-01-2019, 12:07 PM Thread Starter
Member
 
Northern Sol's Avatar
 
Join Date: Jul 2008
Location: Windsor, ON
Posts: 2,986
Hello JohnWR,
They ordered a “clutch pedal position switch”. That was not what was needed. They have now ordered a “clutch pedal start switch”.

Mods: too many to list!

2007 GXP manual. Bought new Sept 2007
The Mean Machine
2009 GXP Coupe Auto # 526. Bought May 2016 - 1800 miles
The Ace of Spades
Northern Sol is offline  
post #58 of 59 (permalink) Old Yesterday, 08:58 AM Thread Starter
Member
 
Northern Sol's Avatar
 
Join Date: Jul 2008
Location: Windsor, ON
Posts: 2,986
Went to the dealership this morning. Told them that she has started every time with no issue for the last two weeks since they adjusted clutch. They told me not to bother replacing part. They said that sometimes when you adjust the clutch that is the end of problem. They are going to hang on to part and if this happens just once ......back to dealership she goes for the part. At this point, I am saving about $200 not getting this done. I like my dealership. Gus Revenburg Windsor. I am doing a road trip in a month so plenty of time to monitor doing local driving. The money can go towards new shoes for my Coupe.

Mods: too many to list!

2007 GXP manual. Bought new Sept 2007
The Mean Machine
2009 GXP Coupe Auto # 526. Bought May 2016 - 1800 miles
The Ace of Spades

Last edited by Northern Sol; Yesterday at 09:18 AM.
Northern Sol is offline  
post #59 of 59 (permalink) Old Yesterday, 09:09 AM
Member
 
easyryderca's Avatar
 
Join Date: Mar 2013
Location: okanagan valley b.c. canada
Posts: 900
Glad to hear your problem may be solved .
easyryderca is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac Solstice Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome