The self proclaimed "official" Pioneer D3 install Thread" - Page 3 - Pontiac Solstice Forum
Reply
 
LinkBack Thread Tools Display Modes
post #31 of 113 (permalink) Old 05-14-2007, 12:24 PM
 
Join Date: Jun 2005
Posts: 52
Quote:
Originally Posted by bpcoxjr View Post
I did this install myself also. The VSS wire on the NA auto trans is on the ECU. Of the three plugs, it's the one on the bottom so you will have to remove all three. Cut into the sheathing to reveal all the various wires and it's the solid yellow wire you want to tap. Good luck. It's pretty easy.
Your my hero. I heard the D3 tends to function better when the VSS is used. And after my last horror experiance in my FJ without a VSS wire, I really want to do this right. Thanks man!!!
CDRacingZX6R is offline  
Sponsored Links
Advertisement
 
post #32 of 113 (permalink) Old 05-14-2007, 06:07 PM
 
Join Date: Jun 2005
Posts: 52
It's being installed right now. Im like a giddy school girl waiting her to get it back.

I took my solstice up to san fransico from Orange County, CA. And it was a blast, only thing missing was a navigation unit and the trip would have been perfect!

By the way, I put 2040 miles on my car in its first seven days of ownership. That a record around here?
CDRacingZX6R is offline  
post #33 of 113 (permalink) Old 05-19-2007, 12:58 PM
Member
 
Pure-Sol's Avatar
 
Join Date: Sep 2006
Location: San Diego!
Posts: 329
So I finally got my AVIC-D3 and the GMOS-LAN-04 and put them together. Yesterday I pulled my car apart and removed my stock stereo. Just as an FYI to anyone out there, if you have Monsoon but no Onstar, you need the GMOS-LAN-02, as the -04 does not fit the car's harness.

Here's my problem: I hooked up the red wire to ACC and the yellow wire to BATTERY like the instructions say, yet my AVIC was on even when my car was off. The only way to turn it off was to undo the negative battery cable. Also, I followed the instructions as far as the RCA jacks for the speakers are concerned, but I got no sound either.

Luckily I was able to get my stock stereo back in and working, so no loss. Also, I have the GPS and reverse sensing lines ran under my transmission tunnel cover, so that's a plus. But I still don't have my AVIC in!! Anyone have any ideas?
Pure-Sol is offline  
post #34 of 113 (permalink) Old 05-19-2007, 09:50 PM
Member
 
russsims's Avatar
 
Join Date: Nov 2005
Location: Cypress, CA--SoCal
Posts: 884
Quote:
Originally Posted by Pure-Sol View Post
So I finally got my AVIC-D3 and the GMOS-LAN-04 and put them together. Yesterday I pulled my car apart and removed my stock stereo. Just as an FYI to anyone out there, if you have Monsoon but no Onstar, you need the GMOS-LAN-02, as the -04 does not fit the car's harness.

Here's my problem: I hooked up the red wire to ACC and the yellow wire to BATTERY like the instructions say, yet my AVIC was on even when my car was off. The only way to turn it off was to undo the negative battery cable. Also, I followed the instructions as far as the RCA jacks for the speakers are concerned, but I got no sound either.

Luckily I was able to get my stock stereo back in and working, so no loss. Also, I have the GPS and reverse sensing lines ran under my transmission tunnel cover, so that's a plus. But I still don't have my AVIC in!! Anyone have any ideas?
Now we hear that the GMOS-04 does not work with the Monsoon with no OnStar. Just ordered this adapter for my install with Monsoon & no OnStar. Damn, now we will have to return the adapter and order the other one. How do you know the 02 adpater will work? Do you have it on good authority from someone in the know?

I was just waiting on the 04 adapter to arrive in the mail to complete my install--glad you headed me off.

2007 Cool GXP 5-Spd.:

-Full Interior Reupholstery
-Carbon Fiber Dash & Rear Panel
-Momo Shift Knob/Hand Brake/Floor Plates
-Gentex Rear View Mirror
-Norm's Cowl Panels & Side Skirts
-Aftershock Front Grill
-TSW Nogaro 19" Rims
-245/40ZR-19 Dunlop SP Sport Maxx XL Tires
-Slotted/Cross Drilled Rotors
-Magnaflow 3" Exhaust

Stereo Upgrade:
-Kenwood DNX8120
-Alpine PDX-4.150 Amp
-MB Quart QSD 216 6.5" Speakers
-8" Boston Sub
-Full Dynamat Extreme Interior
russsims is offline  
post #35 of 113 (permalink) Old 05-19-2007, 09:54 PM
Member
 
Pure-Sol's Avatar
 
Join Date: Sep 2006
Location: San Diego!
Posts: 329
Well, when I say the 02 works, I mean that the plugs fit. No idea if it actually works, since I STILL can't get it to work!

The wires on my radio harnesses are shrinking like crazy lol. I've decided that I'm going to have to suck it up and go to a professional installer. The last attempt I made last night caused my car to not even start up until I physically removed all attachments from the AVIC head unit to my car. Once it was out, she started right up.

I'm pretty discouraged now. I pretty much suck at electrical stuff. It all looks fairly easy, I just followed the directions and I didn't have any issues with them either, they were fairly self-explanatory. But it just never works for me when it comes to wiring!

BTW russ, grats on winning the photo contest in April at kappasphere!

'06 Pure Sol: Kappashield, lil Chromies, Pioneer AVIC-x920BT, M1 wheels, blacked out grille, SOLO from head to tail with Norm's sweet center exit diffuser. DDM Stage II (#13, eat it bad luck)! God it's fast now!
TEAM DDMWORKS
License Plate: PURSOL
Pure-Sol is offline  
post #36 of 113 (permalink) Old 05-19-2007, 10:08 PM
Member
 
russsims's Avatar
 
Join Date: Nov 2005
Location: Cypress, CA--SoCal
Posts: 884
Winning the picture contest was a real surprise. Now what to do with the $50 credit?? May order another Kangaroo pouch for the driver's side and a Solstice key fob. Really do not need anything else they are offering.

Sorry about the install. With my job at General Motors Isuzu Commercial Truck, and GM moving to have International build their medium duty trucks for Chevy and GMC--we are up to our necks reorganizing to just handle Isuzu trucks.

With all this going on I simply do not have the time and patience to do the install myself. Think I have the right installer lined up now and as stated--was only waiting on the adapter in order to bring the car to them. Purchased a bulk pack of Dynamat Extreme to have the full interior covered before the stereo install. Should tighten things up, and less vibration/noise--yes it is a convertible but it still will benefit from this application.

8" JL Audio sub just showed up as well as the Alpine 4" speakers for the rear. Was convinced not to install the rears but both installers I spoke to said for the little money the speakers go for, I should have them installed. They will be driven by the head unit, but the front separates--MB Quarts will be driven by the Alpine 4 channel amp as well as the 8" sub.

Looking forward to having all this installed and notching up the sound a good bit. With the top down all the time, I am tired of not being able to read anything on the face of the factory head unit--have high hopes the AVIC will be a lot more visible in direct sunlight.

Keep us posted as to how things turn out. Will post my install details once things move forward. Going to have the installer take photos along the way.

2007 Cool GXP 5-Spd.:

-Full Interior Reupholstery
-Carbon Fiber Dash & Rear Panel
-Momo Shift Knob/Hand Brake/Floor Plates
-Gentex Rear View Mirror
-Norm's Cowl Panels & Side Skirts
-Aftershock Front Grill
-TSW Nogaro 19" Rims
-245/40ZR-19 Dunlop SP Sport Maxx XL Tires
-Slotted/Cross Drilled Rotors
-Magnaflow 3" Exhaust

Stereo Upgrade:
-Kenwood DNX8120
-Alpine PDX-4.150 Amp
-MB Quart QSD 216 6.5" Speakers
-8" Boston Sub
-Full Dynamat Extreme Interior
russsims is offline  
post #37 of 113 (permalink) Old 05-19-2007, 10:14 PM
Member
 
Pure-Sol's Avatar
 
Join Date: Sep 2006
Location: San Diego!
Posts: 329
Well, I know that the AVIC head unit is very bright. I was actually able to get the GPS working since I couldn't figure out how to turn it off or get the nighttime dimmer to work. I honestly doubt there will be any problem seeing it with the top down. It's very colorful too!

Even though I hope to have this installed before too long, if I get super lazy and it just sits in my garage for a few days until you get yours done (quite possible ) then I would really appreciate the pics!

'06 Pure Sol: Kappashield, lil Chromies, Pioneer AVIC-x920BT, M1 wheels, blacked out grille, SOLO from head to tail with Norm's sweet center exit diffuser. DDM Stage II (#13, eat it bad luck)! God it's fast now!
TEAM DDMWORKS
License Plate: PURSOL
Pure-Sol is offline  
post #38 of 113 (permalink) Old 05-20-2007, 05:05 AM
Member
 
vtail's Avatar
 
Join Date: Jul 2005
Location: Midwest/Northern Indiana
Posts: 215
Quote:
Originally Posted by russsims View Post
Now we hear that the GMOS-04 does not work with the Monsoon with no OnStar. Just ordered this adapter for my install with Monsoon & no OnStar. Damn, now we will have to return the adapter and order the other one. How do you know the 02 adpater will work? Do you have it on good authority from someone in the know?

I was just waiting on the 04 adapter to arrive in the mail to complete my install--glad you headed me off.
I have Monsoon with no OnStar and I can guarantee you that the GMOS-o4 works perfectly with this setup.

Regards,
vtail

Waiting for my GXP!...It's here...It's awesome!

Last edited by vtail; 05-20-2007 at 06:19 AM.
vtail is offline  
post #39 of 113 (permalink) Old 05-20-2007, 10:27 AM
Member
 
MobiusPrime's Avatar
 
Join Date: Sep 2006
Location: inside the Internets
Posts: 167
GMOS-lan-04

I have monsoon with no onstar. I just had the alpine iva-w205 installed and after a few failed attempts (i am almost positive they tried the lan-02 adapter first) they got it working properly with the lan-04 adapter.
MobiusPrime is offline  
post #40 of 113 (permalink) Old 05-20-2007, 11:05 AM Thread Starter
Member
 
Morfious's Avatar
 
Join Date: Nov 2006
Location: Bucks County PA
Posts: 1,003
As far as I know the GMOS-Lan-03 or GMOS-LAN-04 should be the only 2 harnesses you would need. If someone can send me a pdf of the install sheet on the GMOS-LAN-04 I can be of some assistance. I have installed the Lan-03 and could not find the instructions for the Lan-04 posted anywhere. Either post on here or send a PM and I will do what I can for you.

You should not be making alterations to the factory radio harness. You make all the connections between the GMOS harness and the head unit harness. Then you just plug them both together. Sounds like you had the +12v and accessory lines crossed.

Mean GXP Delivered 1/30/2007 $MSRP +$2K

My Stereo Install--> Ultimate AVIC D3 Install thread

Team Solo Performance

Pioneer Avic D3 - Nav System
JL Audio ZR speakers, Alpine PDX 4.150 amp
Solo Performance Street Race exhaust & High Flo Cat
JPM custom interior (Shifter, wheel, console, handles & door panels)
Painted dash and windshield surround
Custom Valentine1 flush radar display
OZ Ultraleggera Wheels
DDM Works Big Brakes, Backbone, intake and intercooler
Morfious is offline  
post #41 of 113 (permalink) Old 05-20-2007, 02:42 PM
Member
 
Pure-Sol's Avatar
 
Join Date: Sep 2006
Location: San Diego!
Posts: 329
Here's the harness for the 04:




And here's the harness for the 02:




I'll try and get the instructions scanned in for the 04. I don't really know how to make it a .pdf though, I've never messed with acrobat.

Anyways, for the harnesses... the 04 just didn't physically fit with the car's harness. The only reason why I grabbed the 02 was that it was the only one with the right shaped connectors.

'06 Pure Sol: Kappashield, lil Chromies, Pioneer AVIC-x920BT, M1 wheels, blacked out grille, SOLO from head to tail with Norm's sweet center exit diffuser. DDM Stage II (#13, eat it bad luck)! God it's fast now!
TEAM DDMWORKS
License Plate: PURSOL
Pure-Sol is offline  
post #42 of 113 (permalink) Old 05-20-2007, 03:17 PM
Member
 
vtail's Avatar
 
Join Date: Jul 2005
Location: Midwest/Northern Indiana
Posts: 215
Quote:
Originally Posted by Pure-Sol View Post
Here's the harness for the 04:




And here's the harness for the 02:




I'll try and get the instructions scanned in for the 04. I don't really know how to make it a .pdf though, I've never messed with acrobat.

Anyways, for the harnesses... the 04 just didn't physically fit with the car's harness. The only reason why I grabbed the 02 was that it was the only one with the right shaped connectors.
Are you sure that is the Metra GMOS-LAN-04??? Mine had two separate connectors and fit perfectly and it didn't look like yours in the pictures. Double check your product numbers...I know that is a simular harness number.

Waiting for my GXP!...It's here...It's awesome!
vtail is offline  
post #43 of 113 (permalink) Old 05-20-2007, 03:27 PM
Member
 
Pure-Sol's Avatar
 
Join Date: Sep 2006
Location: San Diego!
Posts: 329
Quote:
Originally Posted by vtail View Post
Are you sure that is the Metra GMOS-LAN-04??? Mine had two separate connectors and fit perfectly and it didn't look like yours in the pictures. Double check your product numbers...I know that is a simular harness number.
Umm... I think I just figured out my problem. I ordered the GMOS-LAN-04 from Crutchfield, and I just rechecked the package and it is labelled GMOS-LAN-04. But looking at what you said vtail, and also looking at metra's webpage and the picture of the 04 harness, I didn't receive the correct one. So frustrating!

So hopefully I'll be getting the correct one today. Maybe pull apart my car tonight or tomorrow after work and get this stinking thing into the car and get it to work!

Thanks for the clarification vtail. I never even thought of being sent the wrong harness, Crutchfield has a really good reputation so I never even doubted them.

'06 Pure Sol: Kappashield, lil Chromies, Pioneer AVIC-x920BT, M1 wheels, blacked out grille, SOLO from head to tail with Norm's sweet center exit diffuser. DDM Stage II (#13, eat it bad luck)! God it's fast now!
TEAM DDMWORKS
License Plate: PURSOL
Pure-Sol is offline  
post #44 of 113 (permalink) Old 05-20-2007, 03:42 PM
Member
 
vtail's Avatar
 
Join Date: Jul 2005
Location: Midwest/Northern Indiana
Posts: 215
I ordered all my products from Crutchfield...I have nothing but praise for them and their services. Crutchfield did not carry the Metra GMOS-LAN-04 when I ordered about a month ago....had to get it elsewhere....actually through a vendor of Amazon. Hope you get this worked out...the gmos04 definately works in my car!
Regards,
vtail


Just rechecked the Crutchfield site...I think you might have purchased this adaptor...if so, it is not the Metra GMOS-LAN-04

http://www.crutchfield.com/S-49Ft1ik...04&i=120GMOS04

Waiting for my GXP!...It's here...It's awesome!

Last edited by vtail; 05-20-2007 at 03:57 PM. Reason: More info
vtail is offline  
post #45 of 113 (permalink) Old 05-20-2007, 03:56 PM
Member
 
Pure-Sol's Avatar
 
Join Date: Sep 2006
Location: San Diego!
Posts: 329
Quote:
Originally Posted by vtail View Post
I ordered all my products from Crutchfield...I have nothing but praise for them and their services. Crutchfield did not carry the Metra GMOS-LAN-04 when I ordered about a month ago....had to get it elsewhere....actually through a vendor of Amazon. Hope you get this worked out...the gmos04 definately works in my car!
Regards,
vtail


Just rechecked the Crutchfield site...I think you might have purchased this adaptor...if so, it is not the Metra GMOS-LAN-04


http://www.crutchfield.com/S-49Ft1ik...04&i=120GMOS04
yep that's the one. I did it over the phone. When I told the guy I needed the GMOS-LAN-04 (I said it exactly like it looks) he quoted me the one you linked. When I asked him if it was the same thing, seeing as how it didn't have the letters LAN in it, he said yes. I know Crutchfield is a good company, and I hope I can get my money back for this, or at least credit. I just seem to have bad luck with electrical stuff. All of my cars I've worked on, from my 1969 Camaro on have had problems with electrical. You'd think I'd get good at it just from doing it so much!

'06 Pure Sol: Kappashield, lil Chromies, Pioneer AVIC-x920BT, M1 wheels, blacked out grille, SOLO from head to tail with Norm's sweet center exit diffuser. DDM Stage II (#13, eat it bad luck)! God it's fast now!
TEAM DDMWORKS
License Plate: PURSOL
Pure-Sol is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac Solstice Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome