Pontiac Solstice Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I'm a new owner of a 2006 Solstice #442 o the first 1000. I just bought the car a month ago with only 4,897 miles on it. Love the car so far, just have a few small issues. Wanted to ask advice from the pros here :)

My first issue is the 12 volt power outlet below the radio. Mine doesn't work. I tried replacing the fuse (#30 in the Engine fuse box compartment) and still nothing. All the other instrument panel and radio panel gauges work fine.

My next issue is the map lights on my rear view mirror. They work fine when I turn off the car, or open the door. They go off about 20 seconds after the doors are closed. My queston is, when you push them IN to turn them on, say to read a MAP.:willy:.. while the car is on... mine don't work. The light's only seem to work like a normal dome light. They will come on and off as long as the key is not in the ignition. Any ideas?

My final issue of the moment is my convertable soft top. It was working fine up until a few days ago. I went on a road trip to Florida and now the latch mechanism in the center keeps coming "unlatched" for no reason. If the handle is latched and over it is fine, but when you latch it, push it over, and push it up into the groove to make it flush with the roof, it comes unlatched. The handle springs back over to the left.:cuss: Any ideas?

:grouphug:
 

·
Registered
Joined
·
7,157 Posts
First a request, please don't increase the size of your text - it actually makes it more difficult to read (for me anyways). OK, so onto some ideas...

My first issue is the 12 volt power outlet below the radio. Mine doesn't work. I tried replacing the fuse (#30 in the Engine fuse box compartment) and still nothing. All the other instrument panel and radio panel gauges work fine.
Usually, the thing that's happened here is that the connector has come off at the back of the socket (or has failed to have been replaced after the dash has been removed). You can check this by pulling up the shifter boot chrome ring (gently! it's only clipped-in, but the clips can snap off). Pull that up out the way and feel/look in behind the socket.

My next issue is the map lights on my rear view mirror. They work fine when I turn off the car, or open the door. They go off about 20 seconds after the doors are closed. My queston is, when you push them IN to turn them on, say to read a MAP.:willy:.. while the car is on... mine don't work. The light's only seem to work like a normal dome light. They will come on and off as long as the key is not in the ignition. Any ideas?
This is interesting. The switches are common with both the auto and manual 'on' positions. I'm guessing that the ground connection for the manual operation (black wire) is failed, or maybe popped out of the connector at the back. Check the connector first, maybe loose, or just the black wire is.

My final issue of the moment is my convertable soft top. It was working fine up until a few days ago. I went on a road trip to Florida and now the latch mechanism in the center keeps coming "unlatched" for no reason. If the handle is latched and over it is fine, but when you latch it, push it over, and push it up into the groove to make it flush with the roof, it comes unlatched. The handle springs back over to the left.
Hmm. Not heard this before. Are you sure you didn't put the roof down with the handle in the closed/locked position? If so you probably bent the hook bar. Open the roof partially and check the latch, make sure the hook is straight.

Good luck.
 

·
Super Moderator
Joined
·
16,390 Posts
I agree with TS on the last one. Check that the locking hook is not bent.

The latch mechanism is a replaceable unit. I have two spares LOL. If the hook is not bent then I would look at the latch handle mechanism to verify it is not damaged internally.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
Thanks for the info. I fixed the latch by taking out the small plastic circle and tightening the bolt.

The cigarette lighter was exactly what you guys stated the connector in the back of the socket had come off.

As far as the rear view mirror goes the light will come on when the door is open and closed. If I am sitting in the car with the keys out of the ignition they will come on when I turn them on but as soon as I put the key in the ignition and turn the car on the lights will go out ( it's this normal).
 

·
AKA SolWhat?
Joined
·
10,472 Posts
Regarding the mirror lights: on mine when the switch is on it is in the out position. Push the button up or in and the light on that side of the mirror will go out.

Push it again, the button will pop out (down) and the light will come on.

confused yet?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #7
Hi @ DaveO..... The problem I am having wih the map light is when the car is running and both doors are closed I cant get the light to come on no matter which way I push the button in or out. If I Push the buttons in and open the door with the car running the light will come on, when I close the door with the car running and the buttons pushed in the light will go out after about 20 seconds. Just confused as to why they won't come on when the car is running.
 

·
Premium Member
Joined
·
688 Posts
Sounds like you have most of your problems fixed but here is what happened on my 2006...Socket was bad! Ordered a new one from the local Chevy dealer, all is well.
...The glass on the rear view mirror was bad so went to local junk yard and got another one off some GM car, do not know for sure what it came off of but it was exactly the same. Looks like new and works fine.
...my top latch would not engage correctly. Turns out that all I had to do was bend the hook a bit and now it latches smoothly every time.
 

·
Registered
Joined
·
7,157 Posts
Hi @ DaveO..... The problem I am having wih the map light is when the car is running and both doors are closed I cant get the light to come on no matter which way I push the button in or out. If I Push the buttons in and open the door with the car running the light will come on, when I close the door with the car running and the buttons pushed in the light will go out after about 20 seconds. Just confused as to why they won't come on when the car is running.
Like I said, check the plug at the back of the mirror. The map lights have constant power applied, but switched ground. The car (BCM) controls the ground via the grey wire for the door open/unlock etc. The switches 'move' the ground side of the lamps from the grey wire to the black wire (constant ground) when you switch them on manually. Given you have power and the auto ground (and hence switches) work, then the fault must be in the constant ground circuit.

SO... check the mirror plug and specifically the black wire in it, for failure/loss of ground circuit.
 

·
Registered
Joined
·
66 Posts
Like I said, check the plug at the back of the mirror. The map lights have constant power applied, but switched ground. The car (BCM) controls the ground via the grey wire for the door open/unlock etc. The switches 'move' the ground side of the lamps from the grey wire to the black wire (constant ground) when you switch them on manually. Given you have power and the auto ground (and hence switches) work, then the fault must be in the constant ground circuit.

SO... check the mirror plug and specifically the black wire in it, for failure/loss of ground circuit.

:agree: I was having the same issue until I bumped the mirror and the plug fell off the mirror
 

·
Registered
Joined
·
16 Posts
Discussion Starter #11
So I took the mirror off and checked the plug and the wires. I plugged it back in and now with the key in the ignition and the car running, when I push the buttons in on the mirror I get the passanger side to work but not the drivers side.

Thanks for the info TomatoSoup I will keep trouble shooting I think it might be a short or I may need to try another mirror to get both lights to come on.
 
1 - 11 of 11 Posts
Top