Pontiac Solstice Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter · #1 ·
driving down the road, transmission goes into a lower gear, then engine revs almost likes it in neutral, then it goes back to the right gear. Only have 20,000 miles. the next day the car shifted normaly and no service engine lights have ever come on. Any ideas?
thanks
 

·
Premium Member
Joined
·
17,548 Posts
This is a new one to me. Have seen many instances of hard downshifts, mostly due to failing or failed servo position servos.

This thread is a kind of compilation of what we know about how the auto works.

http://www.solsticeforum.com/forum/f12/auto-transmission-suckage-65252/

Its possible that you have an issue with either the ECM or the TCM. If it repeats this behavior, consider rebooting the car. Pull the battery terminal for 30 minutes which will bring power to zero. Then reapply power and start the car. It will basically clear everything and reload the factory software.
 

·
Registered
Joined
·
75 Posts
Discussion Starter · #3 ·
thanks Rob, Ill try , planning on driving the car across county in a month. Do you think visit to the dealer or a good auto trans shop is in order? It is shifting fine today.
 

·
Premium Member
Joined
·
17,548 Posts
The problem with an intermittent issue like this is that unless the tech can reproduce it they cant fix it.

One other thing you can do is verify that all the connectors are in place and looking good and that all the fuses are sell seated. There have been instances of odd behavior that was eventually traced back to an intermittent electrical issue.
 
1 - 4 of 4 Posts
Top