Pontiac Solstice Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
My wife's 2008 GXP developed a problem this morning. The buttons won't work and the LEDs won't light for the ac, recirc, and the rear defrost. The fan blows but ac won't come on. Has anyone had this problem or know the cause?
 

·
Registered
Joined
·
1,639 Posts
Check the fuses. Both the box under the hood, and the box behind the passenger foot-well.
 

·
Registered
Joined
·
7,260 Posts
Did you check the fuses?

Fuse 10 and/or 15 in the BCM behind the passenger footwell panel.
 

·
Registered
Joined
·
433 Posts
We hope that you found the source of the problem by checking the fuses, as recommended above. If you're still having troubles, keep us posted on your plan of action! We want to help as much as you can.

Sarah (Assisting Erica)
GM Customer Care
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Just did a visual inspection. I'll check them with a meter tonight. I'll also check the ground if the fuses are good. Thanks for the input guys.
 

·
Registered
Joined
·
7,260 Posts
The buttons all run off the circuit board inside the controller. So it's either an overall power or ground issue, or it's a circuit board failure :(
 

·
Registered
Joined
·
5 Posts
Discussion Starter #11
You guys must be right about the lose connection. It started back working just as mysteriously as it stopped. Guess I'll have pull the control panel out and see if I can find the problem. Thanks for all the advice.
 

·
Registered
Joined
·
5,597 Posts
If you're going to dive into the BCM under the passenger footwell, be sure to check the connections BEHIND it. I found one smoked for my blower back there that was causing it to work intermittently.
 

·
Registered
Joined
·
431 Posts
I've got the same issue with my 2008 GXP. My first guess was blown fuse. Glad to see i'm on the right track. I'll make some time this weekend to check it out.
 
1 - 14 of 14 Posts
Top