Pontiac Solstice Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
140 Posts
Discussion Starter #1 (Edited)
Yesterday i had a Solo Mach Shorty installed on my GXP. Everything went great except i only enjoyed it for a few hours......i have now joined the list.... WATER PUMP FAILURE, THE ONLY BRIGHT SIDE WAS IT FAILED RIGHT IN MY HOME DRIVEWAY!!!!!! Arrrgggg I'm on vacation and now she sits in the dealership till they can proceed with it monday morning. here are some links to facebook for install pics and first start video.

https://www.facebook.com/photo.php?fbid=652215268125976&set=gm.10151497613379142&type=1&relevant_count=7&ref=nf


https://www.facebook.com/video/video.php?v=652219078125595
 

·
Registered
Joined
·
7,226 Posts
Yesterday i had a Solo Mach Shorty installed on my GXP. Everything went great except i only enjoyed it for a few hours......i have now joined the list.... WATER PUMP FAILURE, THE ONLY BRIGHT SIDE WAS IT FAILED RIGHT IN MY HOME DRIVEWAY!!!!!! Arrrgggg I'm on vacation and now she sits in the dealership till they can proceed with it monday morning. here are some links to facebook for install pics and first start video.

https://www.facebook.com/photo.php?fbid=652215268125976&set=gm.10151497613379142&type=1&relevant_count=7&ref=nf


https://www.facebook.com/video/video.php?v=652219078125595

How many miles? In the Technical reason for waterpump failures thread it's been suggested that GXPs WPs fail more than the 2.4 due to the turbo heat affecting WP seal.
 

·
Registered
Joined
·
140 Posts
Discussion Starter #5
23715 miles She is stored in the winter and only goes out on fair days. Its not my daily driver. I have owned her since day one.
 

·
Registered
Joined
·
311 Posts
NEGXP- I have 18000K on my GXP and about to run the same setup and my car is like yours, only goes out in fair days and is tucked away in the winter. Should i just beat the problem and replace my pump now?
 

·
Registered
Joined
·
140 Posts
Discussion Starter #7
Not sure what to tell you shadowsonic, after doing alot of reading on the threads here for water pump failures it could be the amount of heat caused by the turbo causing the seals to go on the pump, could be the dex-cool coolant being corrosive over time....one thing is for sure you get NO warning when it goes and like i said above i was glad it happened right in my driveway and not out on the road somewhere. The bad thing right at this time is that when i went to the dealership yesterday morning to get a feel on how things would proceed with the repair i was informed the my technicians wife was involved in a serious accident and he would be out of wok for a few days. My Sol remains there until his return so that he can proceed and i continue my vacation without my car :( I will give an update on how things go when the work is complete.

Maybe Rob the Elder can give his 2 cents on water pump failures for he is our resident guru ! Small Dealer;s knowledge would be nice too but i think he is retired :(
 

·
Registered
Joined
·
5,430 Posts
Actually, the pumps seem to fail either catostrophically or they begin to slowly leak and drip from the weep hole. My 07 N/A started blinking the low coolant light at stops, turns, etc. I took the cue that since it's a closed system, you really shouldn't ever get low - it has to be going somewhere. In my case all I found was a film of coolant around the passenger front of the engine. Maybe it would have lead to a total blow out, maybe not?

New - did you have an in-depth discussion on the change procedure with the dealer?
 

·
Registered
Joined
·
140 Posts
Discussion Starter #10
Yes i have had the in depth discussion but as of now nothing is being done , my techs wife was involved in a serious accident over the weekend so until his return nothing happens. He has been my tech since delivery of my Sol from Wilmington assembly on July5 2007 so i trust him and only him with the job. This has not been a very good vacation for me and not a good time for my tech as well! :(
 
1 - 10 of 10 Posts
Top