Pontiac Solstice Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 · (Edited)
Ok im a little dumb right now, my camshaft position sensor went out on the car, got a engine code "camshaft crankshaft correlation error" i replaced the crankshaft sensor and same issue, so i got a new cam sensor anyone know where its located? I cant seem to find it, ive probably looked at it 50 times but its freezing cold out and my brain isnt working in the cold
 

·
Registered
Joined
·
267 Posts
For what it's worth, and I'm going through this issue now with a P0016, P0299, P0300, P0301, and P0303 codes, be mindful of the differences in the camshaft sensors (rear corners of the motor), camshaft actuator solenoid valves (top front of the valve cover; parts stores want to call them "engine variable timing solenoids, it appears), and the camshaft actuators themselves (which I believe are in contact with the timing chain on the front of the head).

I'll report back, but I'm gathering that if you are getting the P0016 (camshaft intake position sensor correlation) OR the P0017 (camshaft exhaust position sensor correlation) that there is a high likelihood your SENSOR is reading correctly and throwing the code, and your SOLENOID (valve) has often been the culprit.

Heard too much confusion on terminology all over the place, but hope that helps someone. I've replaced my intake solenoid, so I'll see shortly if that addressed the issue.

PS - It is good practice to address the smallest numerical codes first, if that isn't obvious. Maybe that helps someone though.
 

·
Registered
Joined
·
1 Posts
Did someone mention cold? My The Camshaft Position (CMP) actuator engine code came on during acold 15F degrees weather. Got P0016, P0017. According to the GM dealer the timing chain is streached. $1300,
 

·
Registered
Joined
·
9 Posts
Did someone mention cold? My The Camshaft Position (CMP) actuator engine code came on during acold 15F degrees weather. Got P0016, P0017. According to the GM dealer the timing chain is streached. $1300,
Funny, same thing they told me! For me it was a combination of the dealer putting regular oil in the car 6 months ago, and a bad solenoid. Replaced oil with Mobile 1 and replaced the solenoids. Code is gone.
 
1 - 7 of 7 Posts
Top