Pontiac Solstice Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
My door locks are functioning...kind of. They almost always work when the car locks/unlocks automatically, like when reaching 2-3 mph or when I turn the car off. If I use the door switches OR the key fob, the locks will work once, then get continually weaker each time the buttons are pushed. After the 1st time they are almost always too weak to work a 2nd time. When using the key fob the horn also sounds "weaker" for lack of a better term. The horn beep when using the key fob never goes away entirely, just sounds weaker sometimes. Both door locks function just fine using the key in the door so I don't think the cylinders are gunked up. I have a new battery, new positive battery cable, and new terminals that are both very tight connecting the battery (optima red top). Any idea what could be causing this?? It is driving me crazy... Someone posted about this very thing a few years ago but the thread never says what the fix was. Please help!
 

·
Registered
2008 Pontiac Solstice GXP
Joined
·
3,319 Posts
it sounds like you need a new battery in the car.
 

·
Administrator
Joined
·
9,176 Posts
My door locks are functioning...kind of. They almost always work when the car locks/unlocks automatically, like when reaching 2-3 mph or when I turn the car off. If I use the door switches OR the key fob, the locks will work once, then get continually weaker each time the buttons are pushed. After the 1st time they are almost always too weak to work a 2nd time. When using the key fob the horn also sounds "weaker" for lack of a better term. The horn beep when using the key fob never goes away entirely, just sounds weaker sometimes. Both door locks function just fine using the key in the door so I don't think the cylinders are gunked up. I have a new battery, new positive battery cable, and new terminals that are both very tight connecting the battery (optima red top). Any idea what could be causing this?? It is driving me crazy... Someone posted about this very thing a few years ago but the thread never says what the fix was. Please help!
Do you get the same symptoms with the engine running?
 

·
Registered
Joined
·
7,422 Posts
Do you get the same symptoms with the engine running?
Can you lock the car with the remote while the engine is running? :D

BUT, given the car automatic lock/unlock works, I think that this reinforces what you mean -- that you are agreeing with kg that the battery's bad.
 

·
Administrator
Joined
·
9,176 Posts
Can you lock the car with the remote while the engine is running? :D

BUT, given the car automatic lock/unlock works, I think that this reinforces what you mean -- that you are agreeing with kg that the battery's bad.
More like wondering if repeated lock/unlocks get weaker, since the auto lock/unlock is a single event.

I do have a pretty low opinion of the Optima batteries in street cars, but another real possibility is a corroded ground.
 

·
Registered
Joined
·
5,932 Posts
OP says "new battery". I'm going with ground strap corrosion but would expect other oddities to be going on also.

Then again, you can buy an brand new "old" battery especially if you buy a higher $$ unit from a place like WalMart that doesn't move a lot of them.
 

·
Administrator
Joined
·
9,176 Posts
OP says "new battery". I'm going with ground strap corrosion but would expect other oddities to be going on also.

Then again, you can buy an brand new "old" battery especially if you buy a higher $$ unit from a place like WalMart that doesn't move a lot of them.
Yes, I have learned to never assume that a new part is good. I once installed a generator (AKA alternator) that was bad out of the box. When i took it back to the store the desk guy didn't understand why i wanted him to test the second replacement.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
My door locks are functioning...kind of. They almost always work when the car locks/unlocks automatically, like when reaching 2-3 mph or when I turn the car off. If I use the door switches OR the key fob, the locks will work once, then get continually weaker each time the buttons are pushed. After the 1st time they are almost always too weak to work a 2nd time. When using the key fob the horn also sounds "weaker" for lack of a better term. The horn beep when using the key fob never goes away entirely, just sounds weaker sometimes. Both door locks function just fine using the key in the door so I don't think the cylinders are gunked up. I have a new battery, new positive battery cable, and new terminals that are both very tight connecting the battery (optima red top). Any idea what could be causing this?? It is driving me crazy... Someone posted about this very thing a few years ago but the thread never says what the fix was. Please help!
it sounds like you need a new battery in the car.
Battery is a new optima red top, build date is less than a year old…I’ll have it checked out though.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #9 ·
OP says "new battery". I'm going with ground strap corrosion but would expect other oddities to be going on also.

Then again, you can buy an brand new "old" battery especially if you buy a higher $$ unit from a place like WalMart that doesn't move a lot of them.
Would this be the engine block ground on the passenger side? I took that one off, cleaned, and put back on, no change.
 
1 - 11 of 11 Posts
Top