Pontiac Solstice Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
My check engine light came on. Had the code read= P0700.
I checked the fluid level...good.
I disconnected the battery to reset everything...still CEL.
I disconnected the TCM let it sit unplugged for about an hour...still CEL.
Advice from others: TCM sneeds to be replaced.
Any thoughts?
 

·
Super Moderator
Joined
·
7,544 Posts
The error code P0700 means that the TCM requested the MIL be turned on. It does not mean that the TCM has to be replaced.

Normally there will be additional code, since the TCM needs a reason to turn on the MIL.

Are you getting any driveability issues? Is the car doing anything new?
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
The only thing it seems to be doing is hard down shifts between 3rd to 2nd and 2nd to 1st. Otherwise it seems to be fine. The upshifts seem ok.
 

·
Super Moderator
Joined
·
7,544 Posts
The only thing it seems to be doing is hard down shifts between 3rd to 2nd and 2nd to 1st. Otherwise it seems to be fine. The upshifts seem ok.
Replace the engine's variable valve timing solenoids. Very easy, and $30-ish each. There are discussions about it, with the main one titled "Transmission Suckage".
 

·
Registered
Joined
·
19 Posts
Discussion Starter #6
Well....


TADA!!! Replace my VVT solenoids with BWD versions...wanted to avoid the AC Delco versions. Took maybe 10 minutes. First test drive...drove well, but CEL was still on. Got really nervous. Second test drive...CEL went out before I left the yard. Drove a few miles, with the top down of course, and it drove better than it ever has. JohnWR, thank you so much for your input.

Now I will tackle other issues....
 

·
Super Moderator
Joined
·
7,544 Posts
Glad that it worked.

There is help for your other issues here too!
 
1 - 7 of 7 Posts
Top