Pontiac Solstice Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hello,

I just bought a used '06 Solstice that for whatever reason had the crank position sensor wiring connector torn off of it. I bought a replacement connector, but the problem is that I do not have the old one, so I have no idea which wires go where. I've got a green, yellow, and purple wire. I have been looking up and down the internet for hours now, and even bought a digital repair manual for the car, but have still not found the information. I'm desperately hoping someone here will know, or would be willing to check for me?

Thanks in advance,
Matt
 

·
Super Moderator
Joined
·
7,544 Posts
Hello,

I just bought a used '06 Solstice that for whatever reason had the crank position sensor wiring connector torn off of it. I bought a replacement connector, but the problem is that I do not have the old one, so I have no idea which wires go where. I've got a green, yellow, and purple wire. I have been looking up and down the internet for hours now, and even bought a digital repair manual for the car, but have still not found the information. I'm desperately hoping someone here will know, or would be willing to check for me?

Thanks in advance,
Matt
Welcome to the forum.

If someone doesn't post it first, I can get you that information in a few hours, when I get access to my service manuals.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Welcome to the forum.

If someone doesn't post it first, I can get you that information in a few hours, when I get access to my service manuals.
Thanks, that'd be awesome. On the Alldatadiy website where I bought the repair manual, I found a diagram showing which wires are which. The problem is, the connector shown in the diagram is slightly different. I've attached two images. The first one is the diagram from the repair manual website. The second attachment is the actual wiring connector I have, which fits perfectly into my crank position sensor. Not sure why there's a different connector being shown on Alldata?
 

Attachments

·
Registered
Joined
·
7,172 Posts
See if this helps...

109470


Or this (though the middle wire color is shown as Tan(?) here:

109471
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
That does, but the only question now is, in my attached picture of the crank position sensor, is #1 on the left or on the right?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
Never mind I see it now. I think that should still be what I need. Thanks so much!
 
1 - 6 of 6 Posts
Top