Pontiac Solstice Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Good morning all,

Here's a quick question for anyone who's installed HIDs. I ordered a light kit from HIDExtra and everything came as expected bulbs and ballasts. When I tried to connect their bulb to the connector from the car it's too small and gets blocked by a little green gasket. I've tried to push it past but no luck. I wanted to know if this is common with the H13 bulb or is it just this manufacturer and I should try another? Or if it's not a big deal can I just shave the gasket down to make it fit (I'm not sure if it's to keep out moisture). Thanks in advance for your help!
 

·
Registered
Joined
·
138 Posts
Make sure the pins are lining up if not it wont push past the gasket, fix is to bend the pins a little so they line up right. Also there should be a "key tab" that sets the polarity make sure you have this in the correct position.

Pictures of both male and female terminals would be helpful to give you advise.

--Christian
 

·
Registered
Joined
·
7,152 Posts
I found the following with my HID plug. You may have the same issue (a Dremel is your friend!):

 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Thanks for your responses. I took a closer look at the 2 bases and realized that in the new bulb, there's a piece of plastic for stability i'm assuming that runs inside the connector that's blocking it from making a full connection. It sucks, but these are going back as I'd rather not modify the connector coming from the car. I guess all H13s aren't created equal...

Happy Driving.

Nyika
 

·
Registered
Joined
·
183 Posts
SaME problem

Thanks for your responses. I took a closer look at the 2 bases and realized that in the new bulb, there's a piece of plastic for stability i'm assuming that runs inside the connector that's blocking it from making a full connection. It sucks, but these are going back as I'd rather not modify the connector coming from the car. I guess all H13s aren't created equal...

Happy Driving.

Nyika
I am having the same problem. What company did you go with in order to have Hid headlights. thanks jmac
 

·
Registered
Joined
·
1,104 Posts
In fairness to OEM Stability and 'warranty'....most should not do this.

But if you want a reliable connection, I say, line up the plus, match wires, cut pigtails and solder wires.....

Every single H13 kit I've ever installed (I've installed a fair share, on many different vehicles) I've only had 2 or 3 maybe that have fit 100% without issues....it seems as though all manufacturers made their own H13 plugs without thinking of the aftermarket
 

·
Registered
Joined
·
221 Posts
Anyone that has an HID kit in their solstice and would like to have spare parts can send me a PM. I have bulbs, ballast, and cancelers for both the 35W and 55W.
 
1 - 7 of 7 Posts
Top