Pontiac Solstice Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
174 Posts
Discussion Starter #1
Went to look at my car tonight at the dealer and the passenger side of the hood would not latch down. Anybody have this problem? Sorry, I could not find a thread on this and if there is sorry for the duplication.
 

·
Registered
Joined
·
621 Posts
buckeyewilky said:
Went to look at my car tonight at the dealer and the passenger side of the hood would not latch down. Anybody have this problem? Sorry, I could not find a thread on this and if there is sorry for the duplication.
I have to drop mine a couple inches to get the drivers side to latch. If I just let to gently fall it won't latch.
 

·
Registered
Joined
·
83 Posts
I had the same problem. Pass side was sitting up about 1/2". I droped it and it lined up real well. I think a little more oil will do the trick.
 

·
Registered
Joined
·
2,171 Posts
buckeyewilky said:
We dropped the hood several inches and it still did not latch on the passenger side.
Sounds like an adjustment issue. Mine latches perfectly, but I guess that doesn't help you one wee little bit, does it? :D
 

·
Premium Member
Joined
·
7,210 Posts
Off topic but also don't forget the little tip someone gave about opening the doors before slamming the hood. Protects the paint from potential chip on the vertical gap where hood meets fender.
 

·
Registered
Joined
·
230 Posts
buckeyewilky said:
Went to look at my car tonight at the dealer and the passenger side of the hood would not latch down. Anybody have this problem? Sorry, I could not find a thread on this and if there is sorry for the duplication.
I have this problem and I have to close the hood from the passenger side of the car to get it to close flush.
 

·
Registered
Joined
·
70 Posts
buckeyewilky said:
Went to look at my car tonight at the dealer and the passenger side of the hood would not latch down. Anybody have this problem? Sorry, I could not find a thread on this and if there is sorry for the duplication.
There is a post by Toyman that explaines how to correct the problem. It's a very simple adjustment. If you view all post by him, it is the 11th one.
 

·
Registered
Joined
·
142 Posts
buckeyewilky said:
Went to look at my car tonight at the dealer and the passenger side of the hood would not latch down. Anybody have this problem? Sorry, I could not find a thread on this and if there is sorry for the duplication.
I had the same problem. It is probably the cable. Where the cable ties into the pull release inside the car. Mine popped out and the passenger side would not latch. Let me know how you make out.
 

·
Premium Member
Joined
·
8,901 Posts
According to the dealer my car was having this issue, but they adjusted the hood for me before I arrived so it would close correctly. Took them less then 5 minutes to fix.
 

·
Premium Member
Joined
·
481 Posts
Fixing the hood latch problem

I posted a few weeks ago about the black plastic screw/bolt things on underside of the hood and how by turning it in or out, you can make the hood latch......but I still had problems and only could get it to latch by turning the thing in so that the hood was too low to line up well with the fender.

I FIXED IT BY: There is a "U" shaped thing that hangs down (it has a flat bottom on the "U") I unscrewed it from the underside of the hood (the nuts are welded in place and won"t fall down).....then I put a washer on each bolt and screwed it back in place. This allowed the "U" thing to be a little lower so it goes into the latching part further and now my hood shuts well and lines up with the fender.
 

·
Registered
Joined
·
230 Posts
toyman said:
I posted a few weeks ago about the black plastic screw/bolt things on underside of the hood and how by turning it in or out, you can make the hood latch......but I still had problems and only could get it to latch by turning the thing in so that the hood was too low to line up well with the fender.

I FIXED IT BY: There is a "U" shaped thing that hangs down (it has a flat bottom on the "U") I unscrewed it from the underside of the hood (the nuts are welded in place and won"t fall down).....then I put a washer on each bolt and screwed it back in place. This allowed the "U" thing to be a little lower so it goes into the latching part further and now my hood shuts well and lines up with the fender.
This fix worked for me. Thanks Toyman ! :)
 

·
Registered
Joined
·
6 Posts
buckeyewilky said:
Went to look at my car tonight at the dealer and the passenger side of the hood would not latch down. Anybody have this problem? Sorry, I could not find a thread on this and if there is sorry for the duplication.

hey, i just have a 100 miles on mine, but went to look and can't find the hood release.... Do you know where it is?
 

·
Premium Member
Joined
·
786 Posts
SunbirdSolstice said:
hey, i just have a 100 miles on mine, but went to look and can't find the hood release.... Do you know where it is?
SunbirdSolstice

Your question really made me laugh out loud :lol: I felt your pain :willy: It took me a few minutes, fumbling around under the hood to find the release. I felt really silly since my friends were asking me to 'openrup'. I still have trouble..... :willy: :willy:
 

·
Registered
Joined
·
178 Posts
buckeyewilky said:
Went to look at my car tonight at the dealer and the passenger side of the hood would not latch down. Anybody have this problem? Sorry, I could not find a thread on this and if there is sorry for the duplication.


I just got my car Friday. I opened my hood for one of my coworkers to see the engine and I had a hard time getting it to catch. I have owned several Corvettes so I know how to drop the hood. Mine was on the drivers side.
I am not sure if it was due to the weather or miss aligned. I plan to look at it this week-end to see it it still does not want to lock.
I would take it back to the dealer for adjustment if it continues. You dont want to be slamming the hood down hard everytime.
 

·
Premium Member
Joined
·
42 Posts
Had the very problem on the 07 I just bought and the two washers under the u shaped part of the latch on the hood on the drivers side that was not catching solved the problem.

William
 
1 - 20 of 24 Posts
Top