Pontiac Solstice Forum banner

1 - 7 of 7 Posts

·
Registered
2007, Solstice GXP, 5 speed
Joined
·
2 Posts
Discussion Starter #1
The button on my steering wheel ( lower button) sticks down when pushed. Makes clearing items hard do. I can take a
s screwdriver and pop it back up but it sticks down the next time it is pushed. I have sprayed it with Electronic cleaner to no avail. Anyone had this happen or know of a solution to the problem? Info center works fine, just have problem clearing info. 2007 GXP.
 

·
Premium Member
Joined
·
1,269 Posts
sounds like a bit of trash or gunk in the button. You can take that button assembly out to inspect it. There are two little round holes on each side of the steering wheel column right behind the steering wheel . by pushing in these holes with piece of blunt coathangar or a small screwdriver, you can pull the center section with the airbag off the steering column. this will reveal the screws that hold the info buttons in place. I think there is only one screw that holds that button assembly in place.
 

·
Registered
Joined
·
6,992 Posts
I would suggest opening up the steering wheel and undoing/removing the button assembly. It may be that the buttons are still dirty, or they may be mis-aligned in the shell.

The procedure is pretty simple (and there are many threads in the forums on this). Basically:

1. Disconnect the neg cable of the battery (to avoid airbag 'incidents' :) )
2. Remove the airbag - insert an electrical screwdrivers (or similar) in the holes on either side of the steering wheel and push against the spring bars that hold the airbag in place, then pull the airbag out and set to the side (you can leave the wires connected)
3. Undo the one screw holding the button assembly in and disconnect the wire connector.
4. The face/shell and the backplate of the buttons are clipped together with a dozen or so clips around the sides. Just undo each with a screwdriver or pry tool.
5. Clean/adjust/replace
 

·
Registered
2007, Solstice GXP, 5 speed
Joined
·
2 Posts
Discussion Starter #5
Thanks for the help. Button was gummed up. Took it apart and cleaned. Works like new now.
 
1 - 7 of 7 Posts
Top