Pontiac Solstice Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1 (Edited)
This is my first post and need some help from the pros on here. I think my water pump is leaking and took it to the mechanic our warranty sent us to. They did a pressure test and said they couldn't find anything. Not sure if it could be something else other than the water pump or if I need to keep pushing the issue. I have pictures showing the leak but am unable to add them to this thread. I can email them if needed. Thanks for any assistance.

The drip is coming off the main cross member that runs the front of the car between the front wheels right about where the water pump is located.

http://i26.photobucket.com/albums/c111/SYCLONE0182/001.jpg

http://i26.photobucket.com/albums/c111/SYCLONE0182/002.jpg

This is for a 2006 Solstice
 

·
Registered
Joined
·
4,163 Posts
Upload them to photobucket, then click on the pic and then click the share button (last button on the right just above the pic). Now click the word "Link" and then click on the last one at the bottom of the pop-up....then go to a new post here, and use <cntrl> <v> and voila....the pic magically appears!
 

·
Registered
Joined
·
199 Posts
I had to fill up the reservoir twice in the space of two weeks so I brought it to the dealer for investigation. They found nothing the first time but it happened again a week later and when I brought it back, viola, they found the leak and changed out the water pump two weeks before warranty end. I have no idea how they missed it the first time around.

Bob
 

·
Registered
Joined
·
22 Posts
Discussion Starter #4
yes, we have been adding small amounts every time we have driven it and took it to be tested but they didn't find anything so I got worried that it was something else. Thanks for your reply. I'm going to keep an eye on it and if need be take it to a different warranty place this weekend.
 

·
Registered
Joined
·
2,721 Posts
How hot is it where you are? There is some normal "overflow" when the car gets to hot there will be coolant run off that is normal. It will run onto the ground close to the area you are showing in your photos. Although it is still hard to tell. If there is leaking from the pump, you should be able to see it coming off of the pump it's self. Check all of the seems on the water pump for leaks. That's usually where the leaks start to come from.
 

·
Registered
Joined
·
5,422 Posts
The water pump is internal - it's inside the front case of the engine but I believe there is a "weep hole" on that case cover. I could see a pressure test coming up negative especially if the engine wasn't running. It's my understanding that the seals can start to fail and only leak gradually while running in some cases.

Mine was gradual enough that there was never an observable puddle under the car - just a trace of pink on the passenger side lower front of the engine. It was just enough to trip the low coolant light.

Don't let it go long. There have been members here that have experienced catastrophic failure - then you're stuck on the roadside.
 

·
Super Moderator
Joined
·
16,388 Posts
As Chick stated so elequently, there are many instances of the pumps failing gradually such that they leak only when running and hot and not when parked. Then one day, you have coolant all over the ground.

Get it looked at. If you are adding coolant its going somewhere. Most cars go for years and never need coolant.
 

·
Registered
Joined
·
300 Posts
It is not normal to lose coolant, if you are losing coolant you have a leak. It will get worse over time.
 

·
Registered
Joined
·
263 Posts
Those photos make me think there is a decent size cooling leak somewhere, even when very hot, it shouldn't be venting that much coolant from the reservoir. Usually a pressure tester can find even the smallest of leaks. this leads me to believe that they either didn't test it, or if they did, they did a half assed job. I would keep pushing the issue is I were you...
 
1 - 10 of 10 Posts
Top