Pontiac Solstice Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
So when I got my coupe it is clearly a replacement key and fob... looks like one of those generic ones you can get off eBay. The lock and unlock work well enough but it has a “trunk” button. It doesn’t do anything. Did the original have a trunk button that would pop the hatch glass?
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
So the fact mine doesn’t would you think that’s a programming issue with the fob or potentially something on the car?
 

·
Premium Member
Joined
·
691 Posts
So the fact mine doesn’t would you think that’s a programming issue with the fob or potentially something on the car?
There was a common problem with the battery retainer clip coming loose at the soldered joint inside the fob. I would guess that since your fob does work for the doors, the problem is probably with the car.

Bill.
 

·
Premium Member
Joined
·
3,643 Posts
So the fact mine doesn’t would you think that’s a programming issue with the fob or potentially something on the car?
you have to determine if the glove box button pops the coupe back window.

If so, then the key fob is likely the issue.
If the glove box button does not pop the window, then there is a problem inside the car itself.


did you get only 1 key fob with the car ?
 

·
Super Moderator
Joined
·
6,296 Posts
So the fact mine doesn’t would you think that’s a programming issue with the fob or potentially something on the car?
The previous two posts are essentially correct:
Because the remote lock/unlock functions work:
1) If the release button in the glovebox works, the car is OK.
2) The car has been properly programmed to recognize the fob.
3) The most likely problem is the fob's trunk button.

You can open the fob to check and clean the button's contact pad.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #7
Great info... thanks. The glove box button works fine so I’ll pull apart the fob and see if it looks like there is any problems. Unfortunately yes just the one set of keys for the car. I’d like to get another but I’m not sure what the process is. Does it have to go to a GM dealer to get programmed?
 

·
Super Moderator
Joined
·
6,296 Posts
The key is easy. You can get one cut just about anywhere, just make sure that the blank includes the Passkey chip. You can teach it to the car yourself using your existing key .

The fob is not quite as easy since it requires a separate programmer. Dormant sells one that is good for several reprogramming sessions or you can get it done by a dealer or anyone with a Tech2 or equivalent scanner.

Many of us have them, so you may be near someone who would do it for you.
 

·
Registered
Joined
·
6,803 Posts
Unfortunately yes just the one set of keys for the car. I’d like to get another but I’m not sure what the process is. Does it have to go to a GM dealer to get programmed?
You only need to go to the dealer (or buy a programmer) for the remote fob. Additional keys you can do yourself easily - as long as you have at least one working key. Just get a GM-compatible key blank from a hardware store (or Home depot, etc) and get it cut to match your existing key. Then there are simple programming steps to program the anti-theft chip that can be found in your owners manual. (or: https://www.solsticeforum.com/forum/f12/how-program-solstice-remote-keyless-entry-55343/#post832194)
 

·
Premium Member
Joined
·
1,036 Posts
Finally had an extra key made just to open the car as i have locked myself out twice in the last two years. Is this old age?
 

·
Premium Member
Joined
·
33 Posts
Unfortunately yes just the one set of keys for the car.
You might want to check to see if the ignition recall was performed on your coupe. I was only given 1 key when I bought mine used (never did get a fob - my coupe must not have been set up with one when it was made or they were lost by the previous owners). After I had it about a month, the car died while I was driving it. Luckily I have a manual and was able to restart it while it was moving. I checked to see if the recall had been done and it wasn't. The dealer that did the recall work gave me 2 keys. They did ask if I had the additional original key, which I didn't and they still gave me two. If the recall was done you'll have to have one made, if not you should get two keys when the recall work is done. I'm not sure if they give two fobs, it's worth checking out.
 

·
Super Moderator
Joined
·
6,296 Posts
....... - my coupe must not have been set up with one when it was made or they were lost by the previous owners.......
Check the inside of your glove box door. If AU0 is one of the RPO codes listed you have Remote Keyless Entry.

'Soup is correct about not getting fobs and about getting two keys with the ignition switch recall.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #16
Just to take this a step further when I use the remote unlock it peeps the horn. Is this normal? I know they peep when you lock them but I’ve never had one do it with the unlock. I’ll check on the recall.
 

·
Super Moderator
Joined
·
6,296 Posts
Just to take this a step further when I use the remote unlock it peeps the horn. Is this normal? I know they peep when you lock them but I’ve never had one do it with the unlock. I’ll check on the recall.
Horn chirps for locking and unlocking are selectable. If you have an owner's manual the instructions are there.
If you don't have a manual you can download one at mygm.com
 

·
Premium Member
Joined
·
1,036 Posts
I keep the extra key in my wallet John & i have done this by putting my keys on the passenger seat while grabbing my jacket off the passenger seat. My own fault of course. I have AAA so i called them to unlock the car.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #20
Took the fob apart and as you all suspected the leads had come unsoldered. Fixed them which made the panick button work but the trunk release still didn’t work. So I tried manually jumping it on the circuit board and voila... pop went the back glass. So I’m guessing the pad on the rubber insert is the issue. I cleaned it but nothing. I’m thinking maybe some conductive ink on the pad???? Any other ideas?
 
1 - 20 of 28 Posts
Top