Pontiac Solstice Forum banner

181 - 193 of 193 Posts

·
Registered
Joined
·
1,132 Posts
Any other way to get CEL from cat off?

I have the high-flow cat from Solo, and recently installed their cat-back exhaust. Unfortunately, the position of the O2 sensor bung makes it point at the frame, so I can't use one of the long extenders. I tried a shorter extender, about 1.25" long, but the code still sets. Is there another solution to keep the CEL off? My car is due for inspection by the end of this month, and I'm running out of options.
 

·
Registered
Joined
·
1,564 Posts
I have the high-flow cat from Solo, and recently installed their cat-back exhaust. Unfortunately, the position of the O2 sensor bung makes it point at the frame, so I can't use one of the long extenders. I tried a shorter extender, about 1.25" long, but the code still sets. Is there another solution to keep the CEL off? My car is due for inspection by the end of this month, and I'm running out of options.
Why are you asking these questions here? Deal directly with Solo. Their representative on this forum is Steve Mariano (Spiky3480). Go to the source.
 

·
Registered
Joined
·
1,132 Posts
Actually, I've tried their email, too. I finally got a response, and that was to call Jeff, at a Canadian exchange. Someone from Solo checks this area out from time to time, and I had hoped an easy fix could be posted for others to see, if they needed it.
 

·
Vendor
Joined
·
611 Posts
Discussion Starter #184
Hi Wintr. Sorry to hear that you are having troubles. It would be easier to clarify over the phone but I'll give it a shot here. Were we aware that you already had our High Flow Cat when we shipped you the exhaust kit? Were there 2 O2 bungs in the front pipe of the exhaust kit. If there are 2 O2 bungs in the front exhaust pipe the rear most hole is the one to use. If the O2 extender is hitting the frame you can usually loosen the front pipe at the front and reat connection ( also loosen the extra Solo hanger ) and roll the whole pipe towards the drivers side. This will give your pipe more height and will also bring down the O2 bung enough to have the extender miss the frome. Wintr are you at all close to Buffalo or Toronto? We would be happy to do it for you at one of our stores. Please feel free to call me at 905-703-1557 ( Jeff ) Thanks and good luck.
 

·
Registered
Joined
·
1,132 Posts
I don't recall anything about letting you know that I had your cat on the ordering info, but just may have not noticed; the exhaust I bought was the Quiet version for those with high-flow cats and headers. Only one O2 bung in the front pipe, and yes, to get the sensor to clear the frame with the short extender, I had to roll the pipe to the driver's side. The long extender has no chance of a fit.
I'm in St. Louis, MO, so a bit far from you; also, my normal phone can't call that number (it's pre-paid), so I have to use my other phone, which I don't have with me at work. How late in the day do you answer that phone number?
 

·
Registered
Joined
·
1,132 Posts
Well, I found out what caused the code. Since I couldn't keep it from setting, I decided to put the stock cat back in. When I took the Solo cat out, I looked into it, and saw that it had half melted away. Apparently, it won't stand up to headers, their high-flow exhaust, and autocross at or near full throttle for 60 seconds.
 

·
Registered
Joined
·
2,721 Posts
Well, I found out what caused the code. Since I couldn't keep it from setting, I decided to put the stock cat back in. When I took the Solo cat out, I looked into it, and saw that it had half melted away. Apparently, it won't stand up to headers, their high-flow exhaust, and autocross at or near full throttle for 60 seconds.
Yep, join the club.:brentil:
 

·
Registered
Joined
·
8,255 Posts
now if you could work the magic on my NA

had a constant P0420 (Cat converter does not perform to GM specs) for
over a year now.

You guys checked it out a long time ago in Buffalo (unit was put on Sept. 08 in Stoney Creek and the header replaced in July 09) and you told me the CAT was performing fine and I believed Bob....still do. I also discussed this issue with Jeff at Wastegate last year. But, now, the code is unclearable.

I have a buddy who has a way to "mask" the code in the ECM so that it doesn't report and signal the engine light, but could cost me over $100.00

For now I really don't care, because I know it's not an issue..........but if I move to a different state I'm going to have to explain a lot to State Vehicle inspection.

Any suggestions to a guy that's been running SOLO for 4 years now?
 

·
Vendor
Joined
·
611 Posts
Discussion Starter #191
Hi Guys. Sorry to hear about the troubles. The check engine light is just an indicator that something "may" be wrong and the light doesn't hurt the performance in any way. Having said that you don't want the light on mainly because it's an annoyance and it will also mask the engine light should it come on for something important. Converters are a wear item and usually last about 7 years with normal driving. The wide open throttle doesn't seem to hurt the cats as much as when the car runs rich. If the car is running a bit rich the damage gets exaggerated at wide open throttle. Guys if you have any specific questions or concerns please feel free to contact me at 905-703-1557 and I'll do my best to address each problem individually. Thanks.
 

·
Premium Member
Joined
·
157 Posts
Hi Guys. Sorry to hear about the troubles. The check engine light is just an indicator that something "may" be wrong and the light doesn't hurt the performance in any way. Having said that you don't want the light on mainly because it's an annoyance and it will also mask the engine light should it come on for something important. Converters are a wear item and usually last about 7 years with normal driving. The wide open throttle doesn't seem to hurt the cats as much as when the car runs rich. If the car is running a bit rich the damage gets exaggerated at wide open throttle. Guys if you have any specific questions or concerns please feel free to contact me at 905-703-1557 and I'll do my best to address each problem individually. Thanks.
Just got back from Solo outside of Toronto on the 4th of July, I had them install their 1st SQR-2 kit on a Sky and when they removed my old Solo Mach shorty w/resonator the O2 sensor was burned off and the high flow cat was totally empty, and all the wadding was melted and almost totally blocking the resonator. After the New SQR-2 and new high flow cat was installed the car has never run better. Dave and Randy at DDM spent hours and hours trying to figure out why the car was missing and throwing codes, the car just never seemed to run good for any length of time. I'm wondering now if the cat problem and the plugged resonator may have been the problem all along. Oh and yes my sevice dealer was able to clear the codes and my check engine light is off for the 1st time in 2 years. I know that a supercharged engine normally runs a little richer, I just hope the rich condition doesn't cause the wadding to melt again.:thumbs:
 

·
Premium Member
Joined
·
604 Posts
Just got back from Solo outside of Toronto on the 4th of July, I had them install their 1st SQR-2 kit on a Sky and when they removed my old Solo Mach shorty w/resonator the O2 sensor was burned off and the high flow cat was totally empty, and all the wadding was melted and almost totally blocking the resonator. After the New SQR-2 and new high flow cat was installed the car has never run better. Dave and Randy at DDM spent hours and hours trying to figure out why the car was missing and throwing codes, the car just never seemed to run good for any length of time. I'm wondering now if the cat problem and the plugged resonator may have been the problem all along. Oh and yes my sevice dealer was able to clear the codes and my check engine light is off for the 1st time in 2 years. I know that a supercharged engine normally runs a little richer, I just hope the rich condition doesn't cause the wadding to melt again.:thumbs:
How long was the previous set up in?
 
181 - 193 of 193 Posts
Top