Pontiac Solstice Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hi
I have issue with overboost. I have dual 2.5" exhaust pipes (split after stock resonator) all the way back and BSR tune,, everything else is stock. I'm getting P0234 code.
I had exhaust manifold leak. I haven't have any codes. When I fixed the leak now I have P0234. Any thoughts?
Thanks in advance!
 

·
Premium Member
Joined
·
10,472 Posts
Possible causes- Boost pressure sensor harness is open or shorted
- Boost pressure sensor circuit poor electrical connection
- Faulty boost pressure sensor
- Faulty Turbo/Super Charger
- Engine over temperature.
- Ignition misfire exceeds the calibrated threshold.
- Faulty Knock sensor (KS)

Help with thisWhen is the code detected?This diagnostic trouble code (DTC) P0234 will set if the boost pressure sensor signal is above the predicted range.Symptoms- Engine Light ON (or Service Engine Soon Warning Light)P0234 DescriptionThe boost pressure sensor responds to pressure changes in the intake manifold. This pressure is created by the turbocharger and changes with accelerator pedal position (APP) and engine speed. The engine control module (ECM) uses this information to assist in diagnosis of the barometric pressure (BARO) sensor and to provide engine overboost protection. The boost pressure sensor has a 5-volt reference circuit, a low reference circuit, and a signal circuit. The engine control module (ECM) supplies 5 volts to the boost pressure sensor on the 5-volt reference 2 circuit, and provides a ground on a low reference circuit. The boost pressure sensor provides a signal to the ECM on a signal circuit relative to the pressure changes. The ECM monitors the boost pressure sensor signal for voltage outside of the normal range. The ECM calculates a predicted value for the boost pressure sensor. The ECM then compares the predicted value to the actual signal.

Read more: OBD2 - OBDII Code P0234 - Turbocharger/Supercharger 'A' Overboost Condition | Engine-Codes.com
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3 (Edited)
I'll check electrical connections and everything else, see if anything is missing.
I'm pushing 25psi with BSR tune,18psi w/o , it will take few start cycles before engine goes into limp mode when I hit 25psi. Do you thing dual exhaust may cause the problem? Or do I need stage2 upgrade for BSR? Or there maybe something else, like WG?
 
1 - 3 of 3 Posts
Top