Pontiac Solstice Forum banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
19 Posts
Discussion Starter #1
The check engine light came on in my 2007 GXP. I took it to the local Chevy dealer and they replaced the spark plugs with hotter ones. Now the engine misses at about 5000 RPM. I didn't notice the miss right away because I don't always "get on it" that much. Could it be the new spark plugs or do I have other issues?
 

·
Registered
Joined
·
426 Posts
The check engine light came on in my 2007 GXP. I took it to the local Chevy dealer and they replaced the spark plugs with hotter ones. Now the engine misses at about 5000 RPM. I didn't notice the miss right away because I don't always "get on it" that much. Could it be the new spark plugs or do I have other issues?
It could be one of your coil packs:

Car Bogs Out
 

·
Registered
Joined
·
433 Posts
The check engine light came on in my 2007 GXP. I took it to the local Chevy dealer and they replaced the spark plugs with hotter ones. Now the engine misses at about 5000 RPM. I didn't notice the miss right away because I don't always "get on it" that much. Could it be the new spark plugs or do I have other issues?
Have you contacted the dealer who did the work to let them know about the issue? Please keep us updated on what they tell you and send a PM if you feel this isn't addressed correctly for you. I hope you're having a good holiday season in spite of the issue. Thank you.

Matt,

GM Customer Assistance
 

·
Premium Member
Joined
·
1,976 Posts
Have you contacted the dealer who did the work to let them know about the issue? Please keep us updated on what they tell you and send a PM if you feel this isn't addressed correctly for you. I hope you're having a good holiday season in spite of the issue. Thank you.

Matt,

GM Customer Assistance
Thanks for being here Matt and best regards to you and yours for the season.
 

·
Premium Member
Joined
·
19 Posts
Discussion Starter #5
I didn't notice the miss until I was on my way up north to put the car away for winter. The car will come out of storage in April.
 

·
Registered
Joined
·
220 Posts
Is your problem solved? My problem was that the coil pack ignition ground wire was coming loose and eventually melted off then I just had to wire it back to the engine and all has been perfect since then.
 
1 - 7 of 7 Posts
Top