Pontiac Solstice Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
900 Posts
Discussion Starter #1
Okay, I bought some Notto Se 15000k HID's from Car ID about a month ago, the Ignitor on the drivers side headlight does not seem to work everytime. Sometimes it wont ignite at all, sometimes it does, the times it doesn't I can take the bulb out still connected to the harness hold it 90 degrees vertical, flip the headlight switch with my other hand and it ignites everytime, when its in the horizontal position it is hit and miss.

Anyone know how to fix this? or should I ask Car ID for a replacement?
 

·
Registered
Joined
·
98 Posts
Question.... Did you wire these using a new relay/wiring harness or just with the original wiring ??
When I installed mine I had the same issue with one not firing up, so I got a relay harness. Taking full power from the battery was the trick for me.... and voila, no more problems.
 

·
Registered
Joined
·
98 Posts
I used the relay harness they sent with them. It wires to the battery and gives direct power for them, the factory harness just sends signal to them.

Would a bad ground cause this problem?
Most definately. Next step is to re-check ALL wiring connections.
Both positive or ground connections could be the culprit. Once that is done and the problem persists, switch the ballasts from side to side. If the problem follows the ballast you have your answer.

Good luck
 

·
Registered
Joined
·
900 Posts
Discussion Starter #6
Couldnt figure it out, tried everything. Called CarID and talked to Alex. he is shipping me out a replacement bulb for free, I have to send my old one back in the new ones box.

Better than buying one. Pretty good service I think.
 
1 - 7 of 7 Posts
Top