Pontiac Solstice Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter · #1 ·
driving down the road, the gauges all quit, the securty light came on. Pulled over and shut car off, then it would not start , would not even crank. waited 5 min car started and ran fine. No service engine lights on and the security light is off too. what would cause this? its running fine now but need to drive the car from Florida to Michigan. 2007 base, auto, 24000 miles. thanks
 

·
Registered
Joined
·
201 Posts
In my experience on other platforms, GM 3.8L L67, this is a standard crank position sensor symptom.
 
  • Like
Reactions: wildfiglane

·
Premium Member
Joined
·
2,042 Posts
Check the battery terminals, and if the battery has not been replaced, check there first.

When we were working on the Mallett to get it started, it would not start for any reason, it was a ground. Has anyone worked on the car? Every ground has to be tight, especially the ones in the front of the car under the headlights on the frame.
 

·
Administrator
Joined
·
9,712 Posts
A loose or corroded ground may well be your problem, and weak batteries will cause odd problems, so checking those is good advice.
Most auto parts stores will read codes and freeze-frame data for you.
 
  • Like
Reactions: wildfiglane

·
Registered
Joined
·
75 Posts
Discussion Starter · #5 ·
thanks guys, fyi, the battery is a brand new interstate, installed about a month ago. I checked the battery terminals and they are clean and very tight.
 

·
Premium Member
Joined
·
2,042 Posts
Rob is right on that, check there to. We found the four ground wires at the front of the car controlled so much. Had the same type of lights, and as we tightened the grounds on each side, more stuff started working, attaching the final ground on the driver side, the security lights went out and the engine fired. This car as others have said is extremely ground sensitive. There are a lot of areas in the car. One in the back by the antenna, 3 or 4 on the back of the cockpit wall, one or two on the console, and at least 4 under the dash. I just went through the whole wiring harness deal.
 
1 - 7 of 7 Posts
Top