Pontiac Solstice Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Took it to an autozone and had my codes read, was throwing P0110 and "bank 1 lean". The guy said i had a bad cam positioning sensor but thats a different code. I really don't know what to do, bank 1 lean sounds like its a oxygen sensor issue somehow. Please any advice would be great. Thanks everyone :)
 

·
Registered
Joined
·
7 Posts
Too much air or too little fuel. Look for an air leak somewhere behind the MAF - possibly a broken PCV inlet down by the airbox. Alternately, could have low fuel pressure or volume.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Too much air or too little fuel. Look for an air leak somewhere behind the MAF - possibly a broken PCV inlet down by the airbox. Alternately, could have low fuel pressure or volume.
Ok, interesting. Because the guy said I needed a new cam positioning center which was causing the lean airflow. Does tht even make sense? Somehow to me it doesn't.
 

·
Registered
Joined
·
7,161 Posts
Took it to an autozone and had my codes read, was throwing P0110 and "bank 1 lean". The guy said i had a bad cam positioning sensor but thats a different code. I really don't know what to do, bank 1 lean sounds like its a oxygen sensor issue somehow. Please any advice would be great. Thanks everyone :)
Something's wrong here. P0110 is the generic OBD code for Intake Air Temperature Circuit Malfunction. Nothing to do with lean fuel. Here's a (possibly) helpful link: OBD II Code P0110

Bank 1 would be the O2 sensor in frount of the cat. Bank 2 is the rear.
Bank 1 and 2 usually refers to the sides of a V8. In our 4 cyl cars, everything is bank 1. Now O2 sensors may be numbered 1 and 2, in which case 1 is the one in front of the cat (upstream) and 2 is the downstream.
 

·
Registered
Joined
·
5,432 Posts
As a side note. The last time I had the local "chain" auto store pull a code, the dude started trying to google it on his cell phone to tell me what it meant....
 

·
Registered
Joined
·
14 Posts
Yeah I'm also getting a"lean"code P0171. Does anyone have ideas? I've been dealing with this for a few days. I've replaced upstream O2, injector insulators, injector seals, checked MAF, looks fine. I can't hear vac leak. Ruining outta ideas. The idle is a little choppy. When I press the gas pedal it wants to die. But runs fine over idle. Thanks in advance. I'm also getting a random misfire P0300. I've replaced and gapped to 0.030 twice. "Hahn Stage II". The only thing I haven't checked is the coil over plug ignition wires. I don't have anything to check them with. But they seem fine. Nothing loose.
 

·
Registered
Joined
·
7,161 Posts
Yeah I'm also getting a"lean"code P0171. Does anyone have ideas? I've been dealing with this for a few days. I've replaced upstream O2, injector insulators, injector seals, checked MAF, looks fine. I can't hear vac leak. Ruining outta ideas. The idle is a little choppy. When I press the gas pedal it wants to die. But runs fine over idle. Thanks in advance.
Things to try (via google):
http://www.solsticeforum.com/forum/f93/p0171-sys-too-lean-code-solved-63926/
CODE P0171 HOW TO FIX?
 

·
Registered
Joined
·
14 Posts
Yeah I saw this. I don't have this other plug. I haven't tried to clean the MAF so I'm gonna run up and grab some MAF cleaner, but I'm not too sure that's gonna help it looks fine (famous last words) thanks for your help...
 

·
Registered
Joined
·
80 Posts
Have you checked fuel pressure. Last car I had with this code and wanted to stall needed to a fuel pump.
 

·
Registered
Joined
·
14 Posts
Well, I've been playing with different things the last few days and I think I've zeroed in on what I think us the problem. On the side of the throttle body us the electronic connection. It us plastic with a small Steel piece on top of it. I took a length of tubing and put one end on the suspected vacuum leak and the other end to my ear. (don't laugh. This works remarkably well) and I can hear a small high pitched vac leak. I'm going to investigate some ways to seal the area without making a bigger problem while being effective. I wouldn't even notice that I have a leak other than the check engine light coming on. Small stutter from time to time...so very slight. Hopefully this fixes it so I can datalog something to get to Bill do we can optimize my Stage II... (fingers crossed)...
 
1 - 12 of 12 Posts
Top