Pontiac Solstice Forum banner

1 - 10 of 10 Posts

·
Premium Member
Joined
·
1,426 Posts
Discussion Starter #1
I have a triple whammy going on and could use some help. Need to know what would cause all 3 at one time.

P0234 Boost over pressure
P0455 Evaporative Emission Control System Leak Detected (gross leak)
P0106 Manifold Absolute Pressure/Barometric Pressure Circuit Range/Performance Problem

Already changed the gas cap. Weird thing is when this happens I lose all boost, no power at all (kinda like limp mode but doesn't show any limp mode lights) but if I turn off the car and restart, it resets and I have all power back. Until I accelerate again.
 

·
Vendor
Joined
·
1,394 Posts
I have a triple whammy going on and could use some help. Need to know what would cause all 3 at one time.

P0234 Boost over pressure
P0455 Evaporative Emission Control System Leak Detected (gross leak)
P0106 Manifold Absolute Pressure/Barometric Pressure Circuit Range/Performance Problem

Already changed the gas cap. Weird thing is when this happens I lose all boost, no power at all (kinda like limp mode but doesn't show any limp mode lights) but if I turn off the car and restart, it resets and I have all power back. Until I accelerate again.
With the P0455 code I would check your EVAP solenoid - here is a quick video how to:


Get that taken care of first, the others might require a tweak of your tune to remedy. However, I would also pull the MAP sensor on the drivers side charge tube and the MAF located on the intake and clean it with MAF cleaner and re-install.

Hope that helps,
Dave
 

·
Premium Member
Joined
·
309 Posts
I think your problem is here, from the SM-

Diagnostic Aids

• A restriction in the MAP sensor port will cause the sensor to be sluggish or unresponsive.
• The intercooler is connected to the turbocharger and to the throttle body by flexible ductwork that requires the use of special high torque fastening clamps. Verify that they are properly connected and tightened.
• The BARO sensor is integrated within the ECM, and it has a port on the housing that allows it to sense the ambient pressure. A buildup of contamination at this opening may hinder the operation of the BARO sensor.
• A restriction that exists in the exhaust system will hinder the performance of the engine and may cause a DTC P0106 to set. Refer to Restricted Exhaust .


This is for 0106. 234 and 455 both have relationship to MAP sensor leading me to suspect it.
 

·
Premium Member
Joined
·
10,464 Posts
Check for leaks at the turbo hoses, also the solenoid below the turbo, look at your MAF make sure is nice and clean.
Also Dave suggestion is also a must.
 

·
Premium Member
Joined
·
1,426 Posts
Discussion Starter #5
Thanks all and Dave. I went and bought the solenoid tonight, I'll get it changed tomorrow and see what happens. Thanks for your insight.
 

·
Registered
Joined
·
3,441 Posts
jrsno1fan. you tested the solenoid and found it to be bad?
 

·
Registered
Joined
·
292 Posts
If you can blow air through it . It is bad.
Test kit lips.
Your are correct I put the new one on and
the old one as a spare in my emergency kit .
LLLFLY
 

·
Registered
Joined
·
292 Posts
If you can blow air through it . It is bad.
Test kit lips.
Your are correct I put the new one on and
the old one as a spare in my emergency kit .
LLLFLY
 

·
Premium Member
Joined
·
1,426 Posts
Discussion Starter #10
Thanks for all of the input. I got the EVAP solenoid changed and didn't have any trouble "hard" driving home 50 miles. But also figured out that I need a new fuel filler insert, the gas cap is not staying tight. Ordered from the dealership $6.
 
1 - 10 of 10 Posts
Top