Pontiac Solstice Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Hello,
I noticed top boost changes without any reasons. I mean i am living on 770ft above sea level and my area almost flat. Using the same gas all the time. No wastegate mods, nothing made before. Outside temperature did not affect to top boost. Two month ago i have a 19-20 PSI. Then it suddenly changes to 15-16 PSI, ofcourse affecting acceleration. Yesterday i decided to drive around.. and get 19 again!
Any one knows what is going on?
 

·
Registered
Joined
·
94 Posts
varying boost?

Hello,
I noticed top boost changes without any reasons. I mean i am living on 770ft above sea level and my area almost flat. Using the same gas all the time. No wastegate mods, nothing made before. Outside temperature did not affect to top boost. Two month ago i have a 19-20 PSI. Then it suddenly changes to 15-16 PSI, ofcourse affecting acceleration. Yesterday i decided to drive around.. and get 19 again!
Any one knows what is going on?
See my long post about a problem re. "MAP" sensor (it ended up being the Purge valve) and code P0106. A number of people joined in for a lengthy discussion. I think you may be having a similar problem with an O-ring intermittently leaking by that affects the boost. Could be an easy fix by simply removing the MAP sensors (2) and the Purge valve solenoid and applying some silicone grease to the O-rings. Do you have the GMPP upgrade or is it stock?

grandpop07
 

·
Registered
Joined
·
21 Posts
Discussion Starter #3
See my long post about a problem re. "MAP" sensor (it ended up being the Purge valve) and code P0106. A number of people joined in for a lengthy discussion. I think you may be having a similar problem with an O-ring intermittently leaking by that affects the boost. Could be an easy fix by simply removing the MAP sensors (2) and the Purge valve solenoid and applying some silicone grease to the O-rings. Do you have the GMPP upgrade or is it stock?

grandpop07
Thank you for your reply! Will try to find your post however i'll be appreciate for the link.
PS: No mods, no tunes. Absolutely stock. Planing to tune with RPM Motorsports.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #4
I have cleaned and apply silicone for both MAP sensors o-rings. Cleaned and lubriacted o-ring from valve solenoid. Then went to ride. Put the accelerator pedal to the flor and gained 14-15psi on a 1-2 gear. I decided to leave a city and tried go faster. After few minutes i got 20 psi on a higher gears, however only 15-16 psi on a first gear. Then boost grows up to 20psi on a 2-4rd gears. I am not sure but looks like i can't reach 20 psi from 1st gear? Am i missing something?
PS: I do a search on this forum and looks like stock boost is 18psi. So now i am not sure i have no tune on this car. I have a stock exhaust and stock cat but some times i can reach 21psi. I bought this car from USA from insurance company and exported outside US, and i don't know previous owner. So it looks like GMPP tune installed? Is it possible to check some how?
 

·
Super Moderator
Joined
·
15,994 Posts
It is possible that you are seeing the factory tune working as designed.

Boost is limited until the car comes up to temperature.

Boost can be limited in the lower gears to reduce torque and wheel spin.

Boost is a function of air density. If you are at the same altitude and the temperature is 30 then the boost will be less than under the same conditions when the air temperature is 100. It can also be affected by humidity.

Check the condition of your intake ducting to make sure everything is sealed correctly. Inspect the intercooler for any damage or leaks.

The factory tune is designed to produce 260 ft pounds of torque and adjusts boost along with other engine parameters to achieve that level.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #6
It is possible that you are seeing the factory tune working as designed.

Boost is limited until the car comes up to temperature.

Boost can be limited in the lower gears to reduce torque and wheel spin.

Boost is a function of air density. If you are at the same altitude and the temperature is 30 then the boost will be less than under the same conditions when the air temperature is 100. It can also be affected by humidity.

Check the condition of your intake ducting to make sure everything is sealed correctly. Inspect the intercooler for any damage or leaks.

The factory tune is designed to produce 260 ft pounds of torque and adjusts boost along with other engine parameters to achieve that level.
Thank you for your asnwers, i am certainly agree with you.
 
1 - 6 of 6 Posts
Top