Pontiac Solstice Forum banner

1 - 20 of 27 Posts

·
Premium Member
Joined
·
1,106 Posts
Discussion Starter #1
I can still drive the car but have no power will it hurt to drive 20 miles to the dealer. Code showed crank relearn
 

·
Registered
Joined
·
7,205 Posts

·
Registered
Joined
·
1,020 Posts
I can still drive the car but have no power will it hurt to drive 20 miles to the dealer. Code showed crank relearn

This happened to me today also. I heard a noise coming from the engine and then the "Engine Power Reduced" light along with the engine light came on. I was able to get home (about 2 miles) and the dealer said it would be okay to drive it in (8 miles).

Post what you find out about your car. They can't look at mine until Monday :(
 

·
Registered
Joined
·
7,205 Posts
Keep in mind that one is an N/A and the other is a GXP
 

·
Registered
Joined
·
163 Posts
If you get the reduced Engine Power and did the Wester's Mod. Check to see if you tightened the nuts enough. I lost the outer nut while pushing her in the twisties pretty hard. Check engine light came on and I suddenly had a 2.0 NA.
 

·
Registered
Joined
·
7,205 Posts
If you get the reduced Engine Power and did the Wester's Mod. Check to see if you tightened the nuts enough. I lost the outer nut while pushing her in the twisties pretty hard. Check engine light came on and I suddenly had a 2.0 NA.
Oh I popped a hose after I changed the intercooler and I can tell you that a 2.0 N/A is no fun at all ... :lol:
 

·
Registered
Joined
·
4,143 Posts
This happened to me today also. I heard a noise coming from the engine and then the "Engine Power Reduced" light along with the engine light came on. I was able to get home (about 2 miles) and the dealer said it would be okay to drive it in (8 miles).

Post what you find out about your car. They can't look at mine until Monday :(
Your issus is sounds like the hoses may have come off for the intake. There is alot of issues with turbo blowing off the hose due to clamps coming loose.
 

·
Premium Member
Joined
·
1,106 Posts
Discussion Starter #10
This happened to me today also. I heard a noise coming from the engine and then the "Engine Power Reduced" light along with the engine light came on. I was able to get home (about 2 miles) and the dealer said it would be okay to drive it in (8 miles).

Post what you find out about your car. They can't look at mine until Monday :(
..

Same here Tuesday is when they can check it.
 

·
Premium Member
Joined
·
1,106 Posts
Discussion Starter #11
I have a N/A the lose of power happen the other day. The reduced power lite and CEL came on while the wife was driving it. When she got home I figured the problem was I hadnt put the 02 extender on yet, so I put it on and started the car the reduced power lite did not come on the CEL was still on tho.
Went to local auto parts store and had the CEL cleared.. Drove it for acouplke of days no problem.
So today I put the Vector Retuned ECM in Did the security relearn no problems drove around for awhile and then it happened again. CEL and reduced power lite come back on. Took it to the dealership and the Tech states that he was able to reset the limp mode but unable to clear CEL. So I got power back. but not for long went back into limp mode
He stated that it might have to be reprogramed.
So do I take out the Vector ECM and put the original ECM back in since it happen with that one first.
 

·
Registered
Joined
·
7,205 Posts
With the Vector ECU you need to do both a security and case learn. If you know someone with a dashhawk you can do the case learn.
 

·
Registered
Joined
·
505 Posts
Sounds like there is a definate problem with the car if it did it with BOTH ECM's I'd put the stock ECM in and take it to the dealer, or at the very least just get me the Codes its throwing and I'll see if I can dig up what might be causing it for you.
 

·
Registered
Joined
·
1,020 Posts
Your issus is sounds like the hoses may have come off for the intake. There is alot of issues with turbo blowing off the hose due to clamps coming loose.
Thanks. Over the last couple of weeks I have felt that my cars engine area seemed louder than usually. It just makes me wonder if some hose was loose which might cause it to sound louder and rougher and then it popped off.... It killing me not to be able to drive it and I will taking it down to the dealers tomorrow night. I just worry that if it is a part then I will have the long wait until it comes in.

On another note I told my son about it (he was really into cars before) and he thought it could be a bad tank of gas and it was making adjustments to the timing because of bad gas. I was running really low on gas the day before this happened and I had to stop in a part of town I don't usually go to. I put in the higest grade gas. He said high performance cars can react that way if bad gas is used and it would sound like a box of marbles rattling and that is exactly what it sounded like.

Thanks for your feedback I will post what they find out on Monday!!!!
 

·
Premium Member
Joined
·
1,106 Posts
Discussion Starter #15
Sounds like there is a definate problem with the car if it did it with BOTH ECM's I'd put the stock ECM in and take it to the dealer, or at the very least just get me the Codes its throwing and I'll see if I can dig up what might be causing it for you.
I believe that is what I am going to do is put the stock back in and get the problem fixed and then put the Vector ECM and find somebody with a dash hawk. I also will try and get the codes
 

·
Premium Member
Joined
·
1,106 Posts
Discussion Starter #16 (Edited)
Well I dont have the decrease power lite on , but that is probably due to the battery going dead but the CEL is still on and the code is

P2138
Accelerator Pedal Position Sensor 1-2 Correlation.....What does this mean

I know I still have to have a case relearn.
 

·
Registered
Joined
·
4,811 Posts
DO NOT take it to the dealer with the Vector tuned ECM in it, they can not read the Vector ECM or reprogram it, it is locked. They will replace it and your tune will be gone. Let them play with the stock ECM
 

·
Premium Member
Joined
·
1,106 Posts
Discussion Starter #19
DO NOT take it to the dealer with the Vector tuned ECM in it, they can not read the Vector ECM or reprogram it, it is locked. They will replace it and your tune will be gone. Let them play with the stock ECM

Thank you so much for that info.
But what would cause the code p2138
 

·
Senior Member
Joined
·
5,641 Posts
xtrememedic said:
But what would cause the code p2138
Here is some info:
Conditions for Setting the DTC

P2138
The voltage difference between APP sensor 1 and APP sensor 2 exceeds a predetermined value for more than 2 seconds.

Action Taken When the DTC Sets

• DTC P2120, P2122, P2123, P2125, P2127, P2128, and P2138 are type A DTCs.

• The control module commands the TAC system to operate in the Reduced Engine Power mode.

• A message center or an indicator displays Reduced Engine Power.

• Under certain conditions the control module commands the engine OFF.
An open, short to ground or short to voltage would not set the code, but high resistance would, according to a fault table.


Might start by looking towards the wiring for an issue. First thing to check is the engine harness chaffing at the EBCM mounting bracket.
 
1 - 20 of 27 Posts
Top