Pontiac Solstice Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter · #1 ·
On my 2009 when putting the top up I must manually put that orange thing into the hole right behind the drivers side door for the weatherstripping to sit right otherwise it blocks opening the door with window up. Is this adjustable or must I manually make sure it sits into the hole.
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #4 ·
Latches with no problem but the orange part that sits in the hole right past the door sits outside the hole when closing the top gotta manually push it in the hole before latching
 

·
Registered
Joined
·
281 Posts
Could be the ball socket has broken, had to replace mine. Suggest that you put the top down part way and look in the folds and you will see a rod with ball joints on each end. The top ball does not adjust, my guess it is not the problem. The bottom one was made of plastic & broke easily and later redesigned as metal. The bottom joint is usually the problem. Take a look & let us know. I can direct you to a few other posts that may help. Daddy Rob did this post a few years ago & it has lots of top threads that may help.

http://www.solsticeforum.com/forum/f11/top-window-edge-wear-65050/

Another useful link:

http://www.skyroadster.com/forums/f2/new-owners-top-alignment-window-gaskets-outside-windows-16439/
 

·
Premium Member
Joined
·
555 Posts
I think Steve2150 is having alignment issues where the side of the top aligns right behind the door if I'm reading his post right. I just noticed the other day I'm having the exact same problem. Here's the hole where the top should be aligning



And in this image you can see how the tab that should be aligning in this hole is coming down almost the full width of the tab to the outside of the hole on my car. Note: I put some blue painters tape on the tab so it would be easier to see.



I looked at the passenger side and it is lining up just fine. I searched the forum for a while and I couldn't find this issue being addressed before. So, anyone know how to adjust the top to correct this problem?
 

Attachments

·
Registered
Joined
·
65 Posts
Discussion Starter · #7 ·
CRiggleman, you hit it right on the head, that is the spot I am talking about, each time I latch the top gotta make sure and manually align it with the hole then latch. Is there an adjustment for this?
 

·
Registered
Joined
·
281 Posts
It has been addressed in great detail, just can't find the one I'm looking for. Send me a PM with your email & I'll send a section from he factory manual on how to adjust the top link rods that will help with this.
 
1 - 10 of 10 Posts
Top