Pontiac Solstice Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
Ok so i tried 3 different methods of resetting the ECM to clear codes:

1) Pull ECM cables off of unit
2) Pull fuses 42 & 43
3) Pull negative cable connection to the fuse box

Methods 2 & 3 I tried with no l luck. I waited an hour before replacing the fuses and 15 min before replacing the ground wire but neither method reset the ECM. I know this since the car started on the first try of the ignition and the check light remained on. The only method that worked was disconnecting the ECM itself. Any ideas?

J
 

·
Premium Member
Joined
·
3,263 Posts
I have had success with a Modified #3, disconnection time always greater than one (1) hr.
 

·
Registered
Joined
·
7,150 Posts
The check engine light may be being re-triggered immediately. What are the DTC code(s)?
 

·
Registered
Joined
·
27 Posts
Discussion Starter #7
Well, when I unplugged the ECM for about an hour last time the code was cleared and it took two tries with the key to start the car (from my understanding this is expected after an ECM reset is successful). I read that doing the same with either the fuses of the neg. battery terminal is the same thing as unplugging the ECM directly, just an easier / safer method. As for the code, I don't have the exact # but my scanner came in today so I will post that in my other thread. I'm pretty sure it has to do with the P.O.S. Fujita CAI installed by the last owner but I could be wrong. The original problem is related to my other post about the bypass valve / BOV issue:

http://www.solsticeforum.com/forum/f43/wastegate-did-not-function-now-functions-too-well-74907/
 
1 - 7 of 7 Posts
Top